summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-11-28 16:39:35 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-11-28 16:39:53 +0100
commit0a4c78b387a4693a78657642e4d49d9a2a46ed79 (patch)
tree9c5fada4174c7ec8caf2e64b9065046f7b252f4b /app-admin/cpulimit
parentdev-python/pyicu: bump to 1.9.5 (diff)
downloadgentoo-0a4c78b387a4693a78657642e4d49d9a2a46ed79.tar.gz
gentoo-0a4c78b387a4693a78657642e4d49d9a2a46ed79.tar.bz2
gentoo-0a4c78b387a4693a78657642e4d49d9a2a46ed79.zip
app-admin/cpulimit: Bump to version 2.4
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-admin/cpulimit')
-rw-r--r--app-admin/cpulimit/Manifest1
-rw-r--r--app-admin/cpulimit/cpulimit-2.4.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/cpulimit/Manifest b/app-admin/cpulimit/Manifest
index b2e9b0bde91e..23c6b3bf2d32 100644
--- a/app-admin/cpulimit/Manifest
+++ b/app-admin/cpulimit/Manifest
@@ -1,2 +1,3 @@
DIST cpulimit-1.8.tar.gz 20610 SHA256 8d0cdc3ec3e462f2ddc6debb195e1a4e7a19cce8233211f473d921f1c517d5f5 SHA512 3098236139b092eb706ec2a6b84528a090b3f4b8b3adfc8debda1b92ffa119ed9adc508898e0f98add593561f5f6b67d52e0966de01a682a6e2e885e3c47b0fa WHIRLPOOL f9be855b9a4b010c8456c2841afc3551a9a28bfc4a9ec3211e2c1e312bf43cdce9e1b745cc325342433feca5a73df03860469ea3a966d3bd37f7ad11a1627510
DIST cpulimit-2.2.tar.gz 22224 SHA256 3f64daa5c4ab9245fa6ae5b564a2ffb3ae60677785103a207fd5f9c5c4cc29e4 SHA512 e708b27e969024ed37689341d76979e5041c050c259359c46f988cfc55f571c16c17f48ca63cd93349041b76bb2c314ab69af36634fec5212e49aa0d0cb0a46e WHIRLPOOL cd9f4c1d2258f2beb7e150c349c5fee984d63c1b4b3c6ca50e8c853ddf26924964ea45230e5196478416b6d17be895966476522b3f9b3702e8c9d5196322029f
+DIST cpulimit-2.4.tar.gz 24669 SHA256 a22e373755608048e9b8d4ec0c9309c59eec7178294902acee72b55de2cb24bb SHA512 008dc3fbdcbd8afd875a2a1ce03d609db595c6e110803140c676d3713ea60f4877a1bb8e7aa0e8b669dce31522ad81e2703f616341a0f4cbc69a6b01865b66d0 WHIRLPOOL 39ca5c35d34b19121e367e561b9b47748b4679ad88944a5b3dacea6cdb8f16fe5a551bf5464989f4d4f99b57d6c43f82a4e20303d08cdc870b43c4a9d6d2526a
diff --git a/app-admin/cpulimit/cpulimit-2.4.ebuild b/app-admin/cpulimit/cpulimit-2.4.ebuild
new file mode 100644
index 000000000000..225db27082fb
--- /dev/null
+++ b/app-admin/cpulimit/cpulimit-2.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Limits the CPU usage of a process"
+HOMEPAGE="http://cpulimit.sourceforge.net"
+SRC_URI="mirror://sourceforge/limitcpu/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ tc-export CC
+ # set correct VERSION
+ #sed -i -e "/^#define VERSION/s@[[:digit:]\.]\+\$@${PV}@" cpulimit.c \
+ # || die 'sed on VERSION string failed'
+
+ default
+}
+
+src_install() {
+ local DOCS=( CHANGELOG README )
+ dosbin ${PN}
+ doman ${PN}.1
+ einstalldocs
+}