summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/diradm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/diradm')
-rw-r--r--app-admin/diradm/Manifest1
-rw-r--r--app-admin/diradm/diradm-2.9.7.1.ebuild76
-rw-r--r--app-admin/diradm/metadata.xml12
3 files changed, 89 insertions, 0 deletions
diff --git a/app-admin/diradm/Manifest b/app-admin/diradm/Manifest
new file mode 100644
index 000000000000..6a30392de7e6
--- /dev/null
+++ b/app-admin/diradm/Manifest
@@ -0,0 +1 @@
+DIST diradm-2.9.7.1.tar.bz2 126172 SHA256 0a10f8b8b872a1f985c1f73da0109e8ba5ebde09ccb4760b56e67d4a1b88f2bf SHA512 5052f7b7072cd61eb9c70d23057f6c0d2fa68a151792d7260ca52716c9588c06234d335af84b967df23da4b4a8650502cab3b18900dc15e71f71b0888224993f WHIRLPOOL 31c2b6eaa913aa0a273652958233e0ace3b309063448add6b446a41e48903b984810f0ce668b27efbbca8c558a20a379692a3d7d3997d8481d0dbfe19827adee
diff --git a/app-admin/diradm/diradm-2.9.7.1.ebuild b/app-admin/diradm/diradm-2.9.7.1.ebuild
new file mode 100644
index 000000000000..0f774a147951
--- /dev/null
+++ b/app-admin/diradm/diradm-2.9.7.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="diradm is a nearly complete nss/shadow suite for managing POSIX users/groups/data in LDAP"
+#HOMEPAGE="http://research.iat.sfu.ca/custom-software/diradm/"
+#SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+HOMEPAGE="http://orbis-terrarum.net/~robbat2/"
+SRC_URI="http://orbis-terrarum.net/~robbat2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="samba irixpasswd automount test"
+RDEPEND=">=net-nds/openldap-2.3
+ sys-apps/gawk
+ sys-apps/coreutils
+ sys-apps/grep
+ dev-lang/perl
+ app-shells/bash
+ sys-apps/sed
+ virtual/perl-MIME-Base64
+ samba? (
+ dev-perl/Crypt-SmbHash
+ >=net-fs/samba-3.0.6
+ )"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-perl/Crypt-SmbHash
+ >=net-fs/samba-3.0.6
+ dev-util/dejagnu
+ net-nds/openldap[-minimal]
+ )"
+
+pkg_setup() {
+ use test && elog "Warning, for test usage, diradm is built with all optional features!"
+}
+
+src_configure() {
+ local myconf
+ if use test; then
+ myconf="--enable-samba --enable-automount --enable-irixpasswd"
+ else
+ myconf="`use_enable samba` `use_enable automount` `use_enable irixpasswd`"
+ fi
+ econf ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc CHANGES* README AUTHORS ChangeLog NEWS README.prefork \
+ THANKS TODO KNOWN-BUGS || die
+ if use irixpasswd; then
+ insinto /etc/openldap/schema
+ doins irixpassword.schema || die "Failed irixpassword.schema"
+ fi
+}
+
+pkg_postinst() {
+ elog "The new diradm pulls many settings from your LDAP configuration."
+ elog "But don't forget to customize /etc/diradm.conf for other settings."
+ elog "Please see the README to instructions if you problems."
+ elog "This package is primarily intended for use with nss_ldap & pam_ldap"
+ elog "and populates many default settings from the /etc/ldap.conf used by"
+ elog "those packages, with a further fallback to /etc/openldap/ldap.conf"
+ elog "for server connection settings only."
+}
+
+src_test() {
+ emake -j1 check
+}
diff --git a/app-admin/diradm/metadata.xml b/app-admin/diradm/metadata.xml
new file mode 100644
index 000000000000..278b560d3df8
--- /dev/null
+++ b/app-admin/diradm/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+ <use>
+ <flag name='automount'>Support for automount data in LDAP</flag>
+ <flag name='irixpasswd'>Support for storing separate IRIX passwords</flag>
+ </use>
+</pkgmetadata>