summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/elektra/files/elektra-0.8.3-introduce-attributes.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/elektra/files/elektra-0.8.3-introduce-attributes.patch')
-rw-r--r--app-admin/elektra/files/elektra-0.8.3-introduce-attributes.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-admin/elektra/files/elektra-0.8.3-introduce-attributes.patch b/app-admin/elektra/files/elektra-0.8.3-introduce-attributes.patch
new file mode 100644
index 000000000000..b970544df010
--- /dev/null
+++ b/app-admin/elektra/files/elektra-0.8.3-introduce-attributes.patch
@@ -0,0 +1,27 @@
+--- a/src/include/CMakeLists.txt
++++ b/src/include/CMakeLists.txt
+@@ -22,6 +22,9 @@
+ check_include_file(time.h HAVE_TIME_H)
+ check_include_file(unistd.h HAVE_UNISTD_H)
+
++set (ELEKTRA_DEPRECATED "__attribute__ ((deprecated))")
++set (ELEKTRA_UNUSED "__attribute__ ((unused))")
++
+ configure_file (
+ "${CMAKE_CURRENT_SOURCE_DIR}/kdb.h"
+ "${CMAKE_CURRENT_BINARY_DIR}/kdb.h"
+--- a/src/include/kdbconfig.h
++++ b/src/include/kdbconfig.h
+@@ -30,6 +30,12 @@
+ * to search for user configuration. */
+ #define KDB_DB_HOME "@KDB_DB_HOME@"
+
++/** Declares a parameter as unused. */
++#define ELEKTRA_UNUSED @ELEKTRA_UNUSED@
++
++/** Declares an API as deprecated. */
++#define ELEKTRA_DEPRECATED @ELEKTRA_DEPRECATED@
++
+ /* disable debug output messages */
+ #define DEBUG @DEBUG@
+