summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2016-06-07 18:59:39 +0200
committerUlrich Müller <ulm@gentoo.org>2016-06-07 18:59:39 +0200
commit149f5681f2fbe5c6fadf5f89ade06e7f0d21e21f (patch)
treea204c3cd4167d04ef6170aedce4ab5812eac6740 /app-admin/emacs-updater
parentapp-admin/emacs-updater: Remove old. (diff)
downloadgentoo-149f5681f2fbe5c6fadf5f89ade06e7f0d21e21f.tar.gz
gentoo-149f5681f2fbe5c6fadf5f89ade06e7f0d21e21f.tar.bz2
gentoo-149f5681f2fbe5c6fadf5f89ade06e7f0d21e21f.zip
app-admin/emacs-updater: Version bump, fixes bug 584984.
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'app-admin/emacs-updater')
-rw-r--r--app-admin/emacs-updater/Manifest1
-rw-r--r--app-admin/emacs-updater/emacs-updater-1.15.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/emacs-updater/Manifest b/app-admin/emacs-updater/Manifest
index f3a101464111..10925251f386 100644
--- a/app-admin/emacs-updater/Manifest
+++ b/app-admin/emacs-updater/Manifest
@@ -1 +1,2 @@
DIST emacs-updater-1.14.tar.xz 6920 SHA256 2b5ab546212d48fa8dc5114e4ef7028f8168a306726d04293d5b8314c1508f95 SHA512 849efdb7af61a6ca5854c1afabf38e5898d129c5901712f38293f9fa96f60abbaf97f053f9542ea2d40fd2c7b19f4037aec3e4226aee92e4ce56a3fced3b488b WHIRLPOOL 3296466ddea6da0d720b76ad8b62c9138fa7c23726526572fa7d5ef536a8418e70ab74ce4ebba66ed99db33fd0736ab572fa109e316f057931213fcd9c8f9e27
+DIST emacs-updater-1.15.tar.xz 7020 SHA256 6554e01eddf8cf1e7074e492ddb1a89bfe49b57fe7c3f20fe9aa92b110f97d48 SHA512 8cc7dd3e0e28ae71030c7c5f29d54f24e12adcbd0615f3c598ad262bd233f028c2424c277aac7dff7b4201a2ac24bfab0e05d1fdc07edcee2c184a733f699b8a WHIRLPOOL faa4f62c85ec7103e17c95676f758c123b0de966e2df78067f9628122f69d8e92a3dd3eeac080f24c988b5ba30b811b27df8f7c001d46a50cde9a0e845d0fd20
diff --git a/app-admin/emacs-updater/emacs-updater-1.15.ebuild b/app-admin/emacs-updater/emacs-updater-1.15.ebuild
new file mode 100644
index 000000000000..313518fcd74b
--- /dev/null
+++ b/app-admin/emacs-updater/emacs-updater-1.15.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Rebuild Emacs packages"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="|| ( sys-apps/util-linux app-misc/getopt )"
+RDEPEND="${DEPEND}
+ >=app-portage/portage-utils-0.3
+ virtual/emacs"
+
+src_prepare() {
+ default
+
+ if ! has_version sys-apps/util-linux; then
+ # BSD ships a dumb getopt(1), so use getopt-long instead
+ sed -i -e '/^GETOPT=/s/getopt/&-long/' emacs-updater || die
+ fi
+
+ if [[ -n ${EPREFIX} ]]; then
+ sed -i -e "1s:/:${EPREFIX%/}/:" \
+ -e "s:^\([[:upper:]]*=\)/:\1${EPREFIX%/}/:" \
+ emacs-updater || die
+ fi
+}
+
+src_install() {
+ dosbin emacs-updater
+ doman emacs-updater.8
+}