summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/emacs-updater
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/emacs-updater')
-rw-r--r--app-admin/emacs-updater/Manifest2
-rw-r--r--app-admin/emacs-updater/emacs-updater-1.13.ebuild30
-rw-r--r--app-admin/emacs-updater/emacs-updater-1.14.ebuild36
-rw-r--r--app-admin/emacs-updater/metadata.xml5
4 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/emacs-updater/Manifest b/app-admin/emacs-updater/Manifest
new file mode 100644
index 000000000000..92fb55635cfa
--- /dev/null
+++ b/app-admin/emacs-updater/Manifest
@@ -0,0 +1,2 @@
+DIST emacs-updater-1.13.tar.xz 6976 SHA256 da2aba0a1b264fc8065294614870756015bb2d5ddab920ec675c04b452b61af5 SHA512 78b0ce6aec3969f83bc5ce37d1411deccb1dbfa175718b6223233a74af816c6bf481ac15e81f1adc31ea594ffd187c3c38c08b709275f3c878021a03ee9c3403 WHIRLPOOL aa42bd8eb7ec864d576e1be310285402971550ee56680dd66dd680e97d799ece60f962f895189aeaf1b92c16dbaba9fde082cc4331848859becda505025d865b
+DIST emacs-updater-1.14.tar.xz 6920 SHA256 2b5ab546212d48fa8dc5114e4ef7028f8168a306726d04293d5b8314c1508f95 SHA512 849efdb7af61a6ca5854c1afabf38e5898d129c5901712f38293f9fa96f60abbaf97f053f9542ea2d40fd2c7b19f4037aec3e4226aee92e4ce56a3fced3b488b WHIRLPOOL 3296466ddea6da0d720b76ad8b62c9138fa7c23726526572fa7d5ef536a8418e70ab74ce4ebba66ed99db33fd0736ab572fa109e316f057931213fcd9c8f9e27
diff --git a/app-admin/emacs-updater/emacs-updater-1.13.ebuild b/app-admin/emacs-updater/emacs-updater-1.13.ebuild
new file mode 100644
index 000000000000..036af83dc07e
--- /dev/null
+++ b/app-admin/emacs-updater/emacs-updater-1.13.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Rebuild Emacs packages"
+HOMEPAGE="http://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="http://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=">=app-portage/portage-utils-0.3
+ virtual/emacs"
+
+src_prepare() {
+ if [[ -n ${EPREFIX} ]]; then
+ sed -i -e "1s:/:${EPREFIX%/}/:" \
+ -e "s:^\(EMACS\|SITELISP\)=:&${EPREFIX%/}:" \
+ emacs-updater || die
+ fi
+}
+
+src_install() {
+ dosbin emacs-updater
+ doman emacs-updater.8
+}
diff --git a/app-admin/emacs-updater/emacs-updater-1.14.ebuild b/app-admin/emacs-updater/emacs-updater-1.14.ebuild
new file mode 100644
index 000000000000..f0d97342223f
--- /dev/null
+++ b/app-admin/emacs-updater/emacs-updater-1.14.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Rebuild Emacs packages"
+HOMEPAGE="http://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="http://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="|| ( sys-apps/util-linux app-misc/getopt )"
+RDEPEND="${DEPEND}
+ >=app-portage/portage-utils-0.3
+ virtual/emacs"
+
+src_prepare() {
+ if ! has_version sys-apps/util-linux; then
+ # BSD ships a dumb getopt(1), so use getopt-long instead
+ sed -i -e '/^GETOPT=/s/getopt/&-long/' emacs-updater || die
+ fi
+
+ if [[ -n ${EPREFIX} ]]; then
+ sed -i -e "1s:/:${EPREFIX%/}/:" \
+ -e "s:^\([[:upper:]]*=\)/:\1${EPREFIX%/}/:" \
+ emacs-updater || die
+ fi
+}
+
+src_install() {
+ dosbin emacs-updater
+ doman emacs-updater.8
+}
diff --git a/app-admin/emacs-updater/metadata.xml b/app-admin/emacs-updater/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-admin/emacs-updater/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>