summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-02-19 09:01:57 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-02-26 18:17:23 +0200
commitc546e9a0281f46d984bcbb8a42883cb476e08dfc (patch)
tree52ed6989864e803af04a529d6da2cde6af65be7b /app-admin/filebeat
parentapp-admin/logstash-bin: bump to 7.6.0 (diff)
downloadgentoo-c546e9a0281f46d984bcbb8a42883cb476e08dfc.tar.gz
gentoo-c546e9a0281f46d984bcbb8a42883cb476e08dfc.tar.bz2
gentoo-c546e9a0281f46d984bcbb8a42883cb476e08dfc.zip
app-admin/filebeat: bump to 7.6.0
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14482 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-admin/filebeat')
-rw-r--r--app-admin/filebeat/Manifest1
-rw-r--r--app-admin/filebeat/filebeat-7.6.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-admin/filebeat/Manifest b/app-admin/filebeat/Manifest
index 036aac30f078..ae07ee6723aa 100644
--- a/app-admin/filebeat/Manifest
+++ b/app-admin/filebeat/Manifest
@@ -5,3 +5,4 @@ DIST filebeat-7.2.0.tar.gz 46415588 BLAKE2B a8940e9a4a85e6eac79dca3418d3dcd14c5a
DIST filebeat-7.3.2.tar.gz 49977990 BLAKE2B 6219a382b415572fdea2ff4b0aa3f02b3c1e500d77ed5200b6d5b4334a08b8e91d389ea41b3afe98355f8b20e7f8ecaccf5996f0bb7aad5f10e0f0d69400a0d6 SHA512 75943b251343d28f478f2f19665e4ba31f5bc6e4b26f6e6da8aa062322da4ab8e134c87a9557a97677ba3b22484c44ebaeaeeb87866e0f12e67f1647fe34131a
DIST filebeat-7.4.1.tar.gz 59665819 BLAKE2B 5af538d317713d42d79d43b58344149980d4bf07b99ea6e6b29562cbce8e221f067881b85a78e4b6dee4973f42aaca1108e4941b1c3041df6162885a7c49d57f SHA512 917942f2434ed09ccc998e75d4272ff03ed1536bfa8c7f09d48f11bccdbe0315d298bc3aeab3c66be3ac3d9fabac506c8b797aa4560dceb7f1978ac420d35696
DIST filebeat-7.5.2.tar.gz 64360149 BLAKE2B 2bcbe19b9354c7039c652e6edd4b2cac688b136188f55caaf070dc9d60bd775eb2f0a4016725bf48baa5d26a056f74226d6bec09d1909fcbaf36ad2703d06f2e SHA512 8911e05b489e07f4ec6ee6397e916186ad618bfe97c43c509d564a828a1938eeea6c57cf66f2e93216b5d6b3958e0450d3aab24b65ef7209f0040f66ee36e74a
+DIST filebeat-7.6.0.tar.gz 77777633 BLAKE2B 50d461f2ed254da9ff0987a3bf55a3e7513f74167b2e1fe2c237b756e341a22a3b9a70a423a6c19015d6833ff9fd45777d652bae0a49dac8e2608ad99ef1682e SHA512 93f1e56986e6c983bfaf9781f09072040774c1a02edd2d0ffbf4e5392e0c93a85421123e78244688b89cb62c06a69f1cad9e56c2933a1818aae9a45f64cef892
diff --git a/app-admin/filebeat/filebeat-7.6.0.ebuild b/app-admin/filebeat/filebeat-7.6.0.ebuild
new file mode 100644
index 000000000000..8836479b860d
--- /dev/null
+++ b/app-admin/filebeat/filebeat-7.6.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/go-1.12.9"
+RDEPEND="!app-admin/filebeat-bin"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+S="${WORKDIR}/src/github.com/elastic/beats"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv beats-${PV} "${S}" || die
+}
+
+src_prepare() {
+ default
+
+ # avoid Elastic license
+ rm -r x-pack || die
+
+ # use ${PV} instead of git commit id
+ sed -i "s/\(COMMIT_ID=\).*/\1${PV}/g" "${S}/libbeat/scripts/Makefile" || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" emake -C "${S}/filebeat"
+}
+
+src_install() {
+ keepdir /etc/${PN}
+ keepdir /var/{lib,log}/${PN}
+
+ fperms 0750 /var/{lib,log}/${PN}
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd.1" ${PN}
+
+ docinto examples
+ dodoc ${PN}/{filebeat.yml,filebeat.reference.yml}
+
+ dobin filebeat/filebeat
+}
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ elog "Please read the migration guide at:"
+ elog "https://www.elastic.co/guide/en/beats/libbeat/$(ver_cut 1-2)/upgrading.html"
+ elog ""
+ fi
+
+ elog "Example configurations:"
+ elog "${EROOT}/usr/share/doc/${PF}/examples"
+}