summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-10-01 12:52:32 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-08 13:02:29 +0300
commit2a7cdcfaa16286f48b7872861a283efc0397951c (patch)
tree6930695fe2330b7a9b119c09a0391bf980d36f0e /app-admin/gixy
parentdev-libs/pigpio: new version 78 (diff)
downloadgentoo-2a7cdcfaa16286f48b7872861a283efc0397951c.tar.gz
gentoo-2a7cdcfaa16286f48b7872861a283efc0397951c.tar.bz2
gentoo-2a7cdcfaa16286f48b7872861a283efc0397951c.zip
app-admin/gixy: port to py3.9, correct DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/745651 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-admin/gixy')
-rw-r--r--app-admin/gixy/gixy-0.1.20.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-admin/gixy/gixy-0.1.20.ebuild b/app-admin/gixy/gixy-0.1.20.ebuild
index cc686c970a01..59d45eafa340 100644
--- a/app-admin/gixy/gixy-0.1.20.ebuild
+++ b/app-admin/gixy/gixy-0.1.20.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
DESCRIPTION="Nginx configuration static analyzer"
HOMEPAGE="https://github.com/yandex/gixy"
# Use GitHub source insted PyPi to get tarball with tests
-SRC_URI="https://github.com/yandex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/yandex/gixy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MPL-2.0"
SLOT="0"
@@ -24,7 +25,7 @@ RDEPEND=">=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
>=dev-python/jinja-2.8[${PYTHON_USEDEP}]
>=dev-python/six-1.1.0[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
dev-python/nose[${PYTHON_USEDEP}]
${RDEPEND}