summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-01-22 10:05:06 +0100
committerPacho Ramos <pacho@gentoo.org>2022-01-22 10:14:38 +0100
commit4bef909d807209fc3d5215fe4daff411074ae595 (patch)
tree11e8f18465169e4fe18590af155e59a5bf48c2ea /app-admin/gnome-abrt
parentapp-admin/conky: Remove old. (diff)
downloadgentoo-4bef909d807209fc3d5215fe4daff411074ae595.tar.gz
gentoo-4bef909d807209fc3d5215fe4daff411074ae595.tar.bz2
gentoo-4bef909d807209fc3d5215fe4daff411074ae595.zip
app-admin/gnome-abrt: Bump to 1.4.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-admin/gnome-abrt')
-rw-r--r--app-admin/gnome-abrt/Manifest1
-rw-r--r--app-admin/gnome-abrt/gnome-abrt-1.4.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-admin/gnome-abrt/Manifest b/app-admin/gnome-abrt/Manifest
index 1666bda99a21..9c0e580f8585 100644
--- a/app-admin/gnome-abrt/Manifest
+++ b/app-admin/gnome-abrt/Manifest
@@ -1 +1,2 @@
DIST gnome-abrt-1.4.0.tar.gz 112129 BLAKE2B f3f45c1793c59f4453ef17fd7e24877143cc5d87bdf8cfd6d778d9178005ff6083ce1564f06bb98d9027628bcdd4feb9d98edcbdcc76432c813065d518d0f91a SHA512 eb66040f23a8cba4e015f4f72dee56d782aa3d8bdd90644dce2e7fa1776edc4dc14d69c3722503825db5ff75fa80bde09bbc5bcd9eb6f20209e7e579d8c33a21
+DIST gnome-abrt-1.4.1.tar.gz 115107 BLAKE2B 6706e65f099056118b40e821325aa7861ef256bdf17d824a5222eeaa3355761bfc8f188e7b0a35305f47b66000c0992daa164d955bdf9d3f6005a1eb85b2a3c2 SHA512 c14397f94d39ce1a94247215679a36c0d1db5fee6a162956d5d87a4585207dbc1cafc60bd9b6b5e3cd5f8437a398ab4a983002d6d2a241a01d7d4da6b93060ae
diff --git a/app-admin/gnome-abrt/gnome-abrt-1.4.1.ebuild b/app-admin/gnome-abrt/gnome-abrt-1.4.1.ebuild
new file mode 100644
index 000000000000..f86e1b32f7a0
--- /dev/null
+++ b/app-admin/gnome-abrt/gnome-abrt-1.4.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit meson python-r1
+
+DESCRIPTION="A utility for viewing problems that have occurred with the system"
+HOMEPAGE="https://github.com/abrt/gnome-abrt"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=x11-libs/gtk+-3.10.0:3
+ >=dev-libs/libreport-2.14.0:0=[python,${PYTHON_USEDEP}]
+ >=app-admin/abrt-2.14.0
+ >=dev-python/pygobject-3.29.1:3[${PYTHON_USEDEP}]
+ >=dev-python/pyxdg-0.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ )
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use doc docs)
+ -Dlint=false
+ )
+
+ python_foreach_impl meson_src_configure
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_install() {
+ python_foreach_impl meson_src_install
+ python_foreach_impl python_optimize
+}
+
+src_test() {
+ python_foreach_impl meson_src_test
+}