summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-08-18 09:49:20 +0200
committerPacho Ramos <pacho@gentoo.org>2021-08-18 09:57:49 +0200
commit5ce73312435edb5390064bb084443e18fdf7eeb8 (patch)
tree4784c5c4ce9c400494d905b2e64f1a4d12d2acd6 /app-admin/gnome-abrt
parentMove dev-python/{u-msgpack → u-msgpack-python} (diff)
downloadgentoo-5ce73312435edb5390064bb084443e18fdf7eeb8.tar.gz
gentoo-5ce73312435edb5390064bb084443e18fdf7eeb8.tar.bz2
gentoo-5ce73312435edb5390064bb084443e18fdf7eeb8.zip
app-admin/gnome-abrt: Bump to 1.4.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-admin/gnome-abrt')
-rw-r--r--app-admin/gnome-abrt/Manifest1
-rw-r--r--app-admin/gnome-abrt/gnome-abrt-1.4.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-admin/gnome-abrt/Manifest b/app-admin/gnome-abrt/Manifest
index 90321a1e1bcf..782f24608926 100644
--- a/app-admin/gnome-abrt/Manifest
+++ b/app-admin/gnome-abrt/Manifest
@@ -1 +1,2 @@
DIST gnome-abrt-1.3.6.tar.gz 112255 BLAKE2B d0e87ef5543e84c246f9e98aac8f92984af9e8220357359ffa76f91e00bb35ccb9b60a00c8e0b00d3464ecfc9ddffaeb61fb15b57480066d957a2af44b49c3be SHA512 7bd15c9956d2e4bafce7d1ef73e930f679119fe8ccebda8a27171a5b3b1dfa90255c572e3a0c70606fe389d50079870399b89f61f683896d4ca6380a7d3f7cc2
+DIST gnome-abrt-1.4.0.tar.gz 112129 BLAKE2B f3f45c1793c59f4453ef17fd7e24877143cc5d87bdf8cfd6d778d9178005ff6083ce1564f06bb98d9027628bcdd4feb9d98edcbdcc76432c813065d518d0f91a SHA512 eb66040f23a8cba4e015f4f72dee56d782aa3d8bdd90644dce2e7fa1776edc4dc14d69c3722503825db5ff75fa80bde09bbc5bcd9eb6f20209e7e579d8c33a21
diff --git a/app-admin/gnome-abrt/gnome-abrt-1.4.0.ebuild b/app-admin/gnome-abrt/gnome-abrt-1.4.0.ebuild
new file mode 100644
index 000000000000..f0302b220f12
--- /dev/null
+++ b/app-admin/gnome-abrt/gnome-abrt-1.4.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit meson python-r1
+
+DESCRIPTION="A utility for viewing problems that have occurred with the system"
+HOMEPAGE="https://github.com/abrt/gnome-abrt"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=x11-libs/gtk+-3.10.0:3
+ >=dev-libs/libreport-2.14.0:0=[python,${PYTHON_USEDEP}]
+ >=app-admin/abrt-2.14.0
+ >=dev-python/pygobject-3.29.1:3[${PYTHON_USEDEP}]
+ >=dev-python/pyxdg-0.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ )
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use doc docs)
+ -Dlint=false
+ )
+
+ python_foreach_impl meson_src_configure
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_install() {
+ python_foreach_impl meson_src_install
+ python_foreach_impl python_optimize
+}
+
+src_test() {
+ python_foreach_impl meson_src_test
+}