summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-08-21 05:53:51 -0600
committerTim Harder <radhermit@gentoo.org>2019-08-21 05:55:19 -0600
commitfd48c2d881d9054c79c4b99fd35e0c276b768453 (patch)
tree7eade300772d7103127f34e1e2caf38d266bb2d1 /app-admin/gopass
parentmedia-libs/exiftool: version bump to 11.63 (diff)
downloadgentoo-fd48c2d881d9054c79c4b99fd35e0c276b768453.tar.gz
gentoo-fd48c2d881d9054c79c4b99fd35e0c276b768453.tar.bz2
gentoo-fd48c2d881d9054c79c4b99fd35e0c276b768453.zip
app-admin/gopass: version bump to 1.8.6
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-admin/gopass')
-rw-r--r--app-admin/gopass/Manifest1
-rw-r--r--app-admin/gopass/gopass-1.8.6.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/gopass/Manifest b/app-admin/gopass/Manifest
index 754a37fd6a7e..319b4badd701 100644
--- a/app-admin/gopass/Manifest
+++ b/app-admin/gopass/Manifest
@@ -1,3 +1,4 @@
DIST gopass-1.8.3.tar.gz 6374004 BLAKE2B 1f3b66e8a631d94fbbb33347009a4614f180d7bd30f3d73e98f476fc81a3f5f0aef15c80705b1b4e871f333a3366cc051eb41785082bb90420a5d34f38e35e16 SHA512 bcf8e4cdb37355ae43d0d6d21e3248d3547fb3f1892bb2e8d5d8ddc47a784f75f4f404429733ac824bd66d719fe63fef7a1d58facde65a6d1820ecf14e7bd77e
DIST gopass-1.8.4.tar.gz 6436185 BLAKE2B ecb086717b09a4a5ea24bc4378fd54369628b0319bfe222b2ca11583eb304c84c05513b1d2ca97089152f41903d5dae24f3aa4acc5e2f6c7e948a8d918308d66 SHA512 53440ff95589f21e1ea1d8a03e3565ad6a3b35dd747ecd62f6496fbe9ba51e94e3081142dfcc094a5986828fcf4724280ee0fdebd9cdc05f0d8720aa4f1c89ae
DIST gopass-1.8.5.tar.gz 6561060 BLAKE2B 99d5ba9d5aed396eb4747461b64285d37544e7deaeb7ee7ebd6e3298a8746cdacbae4aa573d87d324703751d5a78efad2735954d8e2a2a8b53549985a4a9952a SHA512 1f451b10aa87141de635650489bf7227c252e10e5139dad274c95d5625db74fec0b8892a468800d3d3c5dd8b3d64f1c93bd6c75a0ba54fe5f6e630c77b2c6c71
+DIST gopass-1.8.6.tar.gz 7072723 BLAKE2B 5ae883c54f8180f8b6da870bd99710f1c740afe9de193c127a3047fa1211641b94ab98e23148d83c6d5b2cd2e3275f644dc875d106c9267e7e0c6342bf0b9a46 SHA512 7acdb095cf8913954044c3206eab020f197542334798c6b94724709c3953b12f7e5b73ce8c1aa4bfd5df3acf1f424b64bfa94f9a8f68fa7116ed14c8a0f2e6f0
diff --git a/app-admin/gopass/gopass-1.8.6.ebuild b/app-admin/gopass/gopass-1.8.6.ebuild
new file mode 100644
index 000000000000..5ca88b63636f
--- /dev/null
+++ b/app-admin/gopass/gopass-1.8.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/gopasspw/gopass"
+
+inherit golang-vcs-snapshot golang-build bash-completion-r1
+
+DESCRIPTION="a simple but powerful password manager for the terminal"
+HOMEPAGE="https://www.gopass.pw/"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.11"
+RDEPEND="
+ dev-vcs/git
+ >=app-crypt/gnupg-2
+"
+
+src_install() {
+ dobin gopass
+
+ local DOCS=( src/${EGO_PN}/{CHANGELOG,CONTRIBUTING}.md src/${EGO_PN}/docs/*.md )
+ einstalldocs
+
+ # install fish completion
+ ./gopass completion fish > "${T}"/${PN}.fish || die
+ insinto /usr/share/fish/vendor_completions.d
+ doins "${T}"/${PN}.fish
+
+ # install bash completion
+ ./gopass completion bash > "${T}"/${PN} || die
+ dobashcomp "${T}"/${PN}
+
+ # install zsh completion
+ ./gopass completion zsh > "${T}"/${PN}.zsh || die
+ insinto /usr/share/zsh/site-functions
+ newins "${T}"/${PN}.zsh _${PN}
+}