summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-08-05 11:02:12 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-06 18:09:12 +0200
commit6ba778ceecf5cd87d8f90c931e891cdff644564a (patch)
treeb9082f17c46ac1a00fbaee9b2bf0ab7487b2b658 /app-admin/graylog
parentsys-cluster/keepalived: drop old (diff)
downloadgentoo-6ba778ceecf5cd87d8f90c931e891cdff644564a.tar.gz
gentoo-6ba778ceecf5cd87d8f90c931e891cdff644564a.tar.bz2
gentoo-6ba778ceecf5cd87d8f90c931e891cdff644564a.zip
app-admin/graylog: bump to 3.3.3
Bug: https://bugs.gentoo.org/733114 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-admin/graylog')
-rw-r--r--app-admin/graylog/Manifest1
-rw-r--r--app-admin/graylog/graylog-3.3.3.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/app-admin/graylog/Manifest b/app-admin/graylog/Manifest
index f0a52eb94a9d..d59d159b6dd1 100644
--- a/app-admin/graylog/Manifest
+++ b/app-admin/graylog/Manifest
@@ -1,2 +1,3 @@
DIST graylog-3.3.1.tgz 129279195 BLAKE2B b3894a453d369f200951d260c0229cec7dbbeb01fcd5df1d8be354c0669c32c1ae3f435a7bad2fc92823f2408fd6e06eded19a56442d6eaa636bd8401f8573a9 SHA512 9e99784e4c349965aafae8c153bd843007dadf664febe7088cfa7561568841d6acb73592d5f57feaece683ea667a535124cdd49e6ed3a05bab13d07239c8b3dd
DIST graylog-3.3.2.tgz 129297286 BLAKE2B a09e8211f39cf5ea57bd05c49ccd2efba4d166e20bbd2bfa9f52d2de0768d54821a002453497545bc8022ee161c8a69080cf8f99d6988eb1a6e56f7ee13fdb9f SHA512 6422f15d75067f5639d1d3c181c29429bf10f2f499179df304441ff1b01a7cc0b29a27361837c7b2ef8b6d33fbd3448fc759e123f59843391838daf3ee353824
+DIST graylog-3.3.3.tgz 129284019 BLAKE2B 35c8dec3becd0cd513e435fec38c296e40a0c330304effb40e40f656702cd791c68ca9c814baf45671d7494d16d4478f9a0b3e44812c4814bea8dc1213f06793 SHA512 6e7445d1bac5addfe4e09f22ba2425859b44720105ba61ec2d819d12a8d693789f717d6fc1bdacb0ef1fe2e4583c405689a60ddd250e4fa17d1d10e70020f75c
diff --git a/app-admin/graylog/graylog-3.3.3.ebuild b/app-admin/graylog/graylog-3.3.3.ebuild
new file mode 100644
index 000000000000..cda5c7e5b52d
--- /dev/null
+++ b/app-admin/graylog/graylog-3.3.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Free and open source log management"
+HOMEPAGE="https://www.graylog.org"
+SRC_URI="https://downloads.graylog.org/releases/graylog/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="strip"
+
+RDEPEND="!app-admin/graylog2
+ acct-group/graylog
+ acct-user/graylog
+ >=virtual/jdk-1.8:*"
+
+DOCS=(
+ COPYING README.markdown UPGRADING.rst
+)
+
+GRAYLOG_DATA_DIR="/var/lib/graylog"
+GRAYLOG_INSTALL_DIR="/usr/share/graylog"
+QA_PREBUILT="${GRAYLOG_INSTALL_DIR}/lib/sigar/libsigar*"
+
+src_prepare() {
+ default
+
+ # Stick to architecture of build host
+ if ! use amd64; then
+ rm -r lib/sigar/libsigar-amd64-*.so || die "Failed in removing AMD64 support libraries"
+ fi
+ if ! use ppc64; then
+ rm -r lib/sigar/libsigar-ppc64-*.so || die "Failed in removing PPC64 support libraries"
+ fi
+ if ! use x86; then
+ rm -r lib/sigar/libsigar-x86-*.so || die "Failed in removing X86 support libraries"
+ fi
+ # Currently unsupported platforms
+ # QA warning galore but testing/patches welcome
+ rm lib/sigar/libsigar-*freebsd*so \
+ lib/sigar/libsigar-*solaris*so \
+ lib/sigar/libsigar-*hpux*.sl \
+ lib/sigar/libsigar-*macosx*.dylib \
+ lib/sigar/libsigar-ia64-*.so \
+ lib/sigar/libsigar-ppc-*.so \
+ lib/sigar/libsigar-s390x*.so \
+ lib/sigar/*winnt* || die "Failed in removing unsupported platform libraries"
+
+ # gentoo specific paths
+ sed -i "s@\(node_id_file = \).*@\1${GRAYLOG_DATA_DIR}/node-id@g; \
+ s@\(message_journal_dir = \).*@\1${GRAYLOG_DATA_DIR}/data/journal@g;" \
+ graylog.conf.example || die
+}
+
+src_install() {
+ default
+
+ insinto /etc/graylog
+ doins graylog.conf.example
+
+ insinto "${GRAYLOG_INSTALL_DIR}"
+ doins graylog.jar
+ doins -r lib plugin
+
+ keepdir "${GRAYLOG_DATA_DIR}"
+
+ newconfd "${FILESDIR}/graylog.confd" graylog
+ newinitd "${FILESDIR}/graylog.initd" graylog
+}
+
+pkg_postinst() {
+ ewarn "Graylog does not depend on need.net any more (#439092)."
+ ewarn
+ ewarn "Please configure rc_need according to your binding address in:"
+ ewarn "/etc/conf.d/graylog"
+ ewarn
+ ewarn "Graylog requires Java >= 8"
+ ewarn "Elasticsearch 5.x or 6.x (does NOT work with 7.x)"
+ ewarn "and MongoDB 3.6 or 4.0 (does NOT work with 4.2)"
+}