summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2021-08-06 12:31:48 +0000
committerIonen Wolkens <ionen@gentoo.org>2021-08-07 08:47:50 -0400
commit73486fdffd530d75e7eca84f0c40b1ebe2f492b9 (patch)
tree812c0c617927b7856b3e3eb74c83f9b5f932fb00 /app-admin/graylog
parentapp-admin/graylog: bump to 4.0.10 (diff)
downloadgentoo-73486fdffd530d75e7eca84f0c40b1ebe2f492b9.tar.gz
gentoo-73486fdffd530d75e7eca84f0c40b1ebe2f492b9.tar.bz2
gentoo-73486fdffd530d75e7eca84f0c40b1ebe2f492b9.zip
app-admin/graylog: bump to 4.1.2
Bug: https://bugs.gentoo.org/806055 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-admin/graylog')
-rw-r--r--app-admin/graylog/Manifest1
-rw-r--r--app-admin/graylog/graylog-4.1.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/graylog/Manifest b/app-admin/graylog/Manifest
index 016605a75895..ebc26dcd1ca9 100644
--- a/app-admin/graylog/Manifest
+++ b/app-admin/graylog/Manifest
@@ -4,3 +4,4 @@ DIST graylog-3.3.14.tgz 129341489 BLAKE2B 33c6c0ef84785a325a5d7cc484fa7cbcbf1bb0
DIST graylog-4.0.10.tgz 190578964 BLAKE2B abc9be077acb7da76fe446a8a580e857abb852b6c811fe34a237527538421777ad12e779b79a85db6c54f477c547451f3c8a9aed6054d1df209626fc4ff95dac SHA512 62b97eb1a8ed49a659fdfeaa48b685e06ecda7c7a556caf29db86a2c149dd3f00c9b51ba48e3f81e3f8b9ed00cb567e86d617553028b41c1e723b373d67ec466
DIST graylog-4.0.5.tgz 163294449 BLAKE2B 3b3c7e74bdfbc37bb4a416733b70d153b399b66cf97215a476aa3304dead0143a60253514c804e6cbeb5b4e2935e79a9e8ff16b88d2067c8820dcc5aaf7331aa SHA512 d9df101560fa0dcf63043c1dd41342caea58d77d24e81da0912270b6b627c1ec1c30900902a8456bcd3dd1281d4d57b499defc4e0da0a58bbc61ad53f1843448
DIST graylog-4.0.7.tgz 190560623 BLAKE2B 329a61bb6e8f08fc670a7f9673c5e67fb197febf8ab85737c651e1f8c3a078e3528d9058f0d707bd1e3ed94fa3dc60c2a70a7f931a8cea79d31c96099a86117c SHA512 991e2eec505cfde6a7254d4fa332c564e81142afec7a3b879a60ca10b7366cba46823c078f043cc5e700e462d2ba7d23fa6774ab3e58903bed91b8b5494c9d5e
+DIST graylog-4.1.2.tgz 197078255 BLAKE2B 1a64529e1000c850fffd5e7566a7b3f87a495e5bf81921e92b464db5ff01046d13cc5d5d172d49b33063a89caf7f4360baff13ce1c6478dd90c50a7c5b1bed88 SHA512 86f2f80c14eb9fc45cc4b1c49a9ae4cd67054199200b87056721e59edd713b0b9a22f184b16f330998a85e0bd36901edf1f816e8ac21497d41a99c52525076fc
diff --git a/app-admin/graylog/graylog-4.1.2.ebuild b/app-admin/graylog/graylog-4.1.2.ebuild
new file mode 100644
index 000000000000..9acb16a593fa
--- /dev/null
+++ b/app-admin/graylog/graylog-4.1.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Free and open source log management"
+HOMEPAGE="https://www.graylog.org"
+SRC_URI="https://downloads.graylog.org/releases/graylog/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="strip"
+
+RDEPEND="!app-admin/graylog2
+ acct-group/graylog
+ acct-user/graylog
+ >=virtual/jdk-1.8:*"
+
+DOCS=(
+ README.markdown UPGRADING.rst
+)
+
+GRAYLOG_DATA_DIR="/var/lib/graylog"
+GRAYLOG_INSTALL_DIR="/usr/share/graylog"
+QA_PREBUILT="${GRAYLOG_INSTALL_DIR}/lib/sigar/libsigar*"
+
+src_prepare() {
+ default
+
+ # gentoo specific paths
+ sed -i "s@\(node_id_file = \).*@\1${GRAYLOG_DATA_DIR}/node-id@g; \
+ s@\(message_journal_dir = \).*@\1${GRAYLOG_DATA_DIR}/data/journal@g;" \
+ graylog.conf.example || die
+}
+
+src_install() {
+ default
+
+ insinto /etc/graylog
+ doins graylog.conf.example
+
+ insinto "${GRAYLOG_INSTALL_DIR}"
+ doins graylog.jar
+ doins -r plugin
+
+ keepdir "${GRAYLOG_DATA_DIR}"
+
+ newconfd "${FILESDIR}/graylog.confd" graylog
+ newinitd "${FILESDIR}/graylog.initd" graylog
+}
+
+pkg_postinst() {
+ ewarn "Graylog does not depend on need.net any more (#439092)."
+ ewarn
+ ewarn "Please configure rc_need according to your binding address in:"
+ ewarn "/etc/conf.d/graylog"
+}