summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2019-02-28 23:44:34 +1100
committerMichael Palimaka <kensington@gentoo.org>2019-02-28 23:45:11 +1100
commit7ff419fb65f255464ca0a854146997e407ba85f9 (patch)
tree84e8088e7d3bbf0f7defdc5768918c15b64a8abb /app-admin/keepass
parentapp-admin/keepass: stabilise 2.41 for amd64/x86 (diff)
downloadgentoo-7ff419fb65f255464ca0a854146997e407ba85f9.tar.gz
gentoo-7ff419fb65f255464ca0a854146997e407ba85f9.tar.bz2
gentoo-7ff419fb65f255464ca0a854146997e407ba85f9.zip
app-admin/keepass: remove 2.40
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'app-admin/keepass')
-rw-r--r--app-admin/keepass/Manifest1
-rw-r--r--app-admin/keepass/keepass-2.40-r1.ebuild113
2 files changed, 0 insertions, 114 deletions
diff --git a/app-admin/keepass/Manifest b/app-admin/keepass/Manifest
index 521f2d8ea96c..909171f86103 100644
--- a/app-admin/keepass/Manifest
+++ b/app-admin/keepass/Manifest
@@ -1,2 +1 @@
-DIST KeePass-2.40-Source.zip 5136918 BLAKE2B 7b5071cbe3bc5f20450a094a4b8969e2e25f6bba27d88ee5c2c25f2706ed3cf18e721ba53ff54c78db6ea1e167cef1108611fc8253a9d6e19eb3f9d1f3317c73 SHA512 222f7e7ef65be8b0d75baa0a6e871d5edad1b570b64f261405b843d7387ec1faeb4138afb8b31934d70eebe0add297681028cb4f3acfcbe4f518c763fe6c0145
DIST KeePass-2.41-Source.zip 5141195 BLAKE2B 7f61efa6d73fbfd5de283567a1673f5757619ebb81f3daa3fba82c887874f2cdb15f74221bf389013fe4cf19c83f00f87de2c596d22a22f5f38b5236dab01e44 SHA512 0d9398f529e004df6a4d3e0b8e34a1324b1806bf44987e9cb2d7535eaf02192662e72c89f1e41b7da01d23b0d686fbbca7a956ef7873fd8b1948847fbf5d27a5
diff --git a/app-admin/keepass/keepass-2.40-r1.ebuild b/app-admin/keepass/keepass-2.40-r1.ebuild
deleted file mode 100644
index 6a0068dce46d..000000000000
--- a/app-admin/keepass/keepass-2.40-r1.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils gnome2-utils xdg-utils
-
-MY_PN="KeePass"
-DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
-HOMEPAGE="https://keepass.info/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="aot"
-
-COMMON_DEPEND="dev-lang/mono"
-DEPEND="${COMMON_DEPEND}
- app-arch/unzip
-"
-RDEPEND="${COMMON_DEPEND}
- dev-dotnet/libgdiplus[cairo]
-"
-
-S="${WORKDIR}"
-PATCHES=( "${FILESDIR}/${PN}-2.36-xsl-path-detection.patch" )
-
-src_prepare() {
- # KeePass looks for some XSL files in the same folder as the executable,
- # we prefer to have it in /usr/share/KeePass. Apply patch using base function.
- # This XSL file will not be upstreamed since the KeePass creator said that
- # including this patch would break the Portable USB version of KeePass
- # (which keeps/looks for xsl files in its own folder)
- default
-
- # Switch into build dir so the mono prepration script works correctly
- pushd Build || die
- source PrepMonoDev.sh || die
- popd || die
-}
-
-src_compile() {
- export MONO_REGISTRY_PATH=/dev/null # bug 659808
-
- # Build with Release target
- xbuild /target:KeePass /property:Configuration=Release || die
-
- # Run Ahead Of Time compiler on the binary
- if use aot; then
- cp Ext/KeePass.exe.config Build/KeePass/Release/ || die
- mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
- fi
-}
-
-src_install() {
- # Wrapper script to launch mono
- make_wrapper "${PN}" "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
-
- # Some XSL files
- insinto "/usr/share/${PN}/XSL"
- doins Ext/XSL/*
-
- insinto "/usr/$(get_libdir)/${PN}"
- exeinto "/usr/$(get_libdir)/${PN}"
-
- doins Ext/KeePass.exe.config
-
- # Default configuration, simply says to use user-specific configuration
- doins Ext/KeePass.config.xml
-
- # The actual executable
- doexe Build/KeePass/Release/KeePass.exe
-
- # Copy the AOT compilation result
- if use aot; then
- doexe Build/KeePass/Release/KeePass.exe.so
- fi
-
- # Prepare the icons
- newicon -s 256 Ext/Icons_04_CB/Finals/plockb.png "${PN}.png"
- newicon -s 256 -t gnome -c mimetypes Ext/Icons_04_CB/Finals/plockb.png "application-x-${PN}2.png"
-
- # Create a desktop entry and associate it with the KeePass mime type
- make_desktop_entry "${PN}" "${MY_PN}" "${PN}" "System;Security" "MimeType=application/x-keepass2;\nStartupWMClass=KeePass2;"
-
- # MIME descriptor for .kdbx files
- insinto /usr/share/mime/packages
- doins "${FILESDIR}/${PN}.xml"
-
- # sed, because patching this really sucks
- sed -i 's/mono/mono --verify-all/g' "${D}/usr/bin/keepass" || die
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-
- if ! has_version x11-misc/xdotool ; then
- elog "Optional dependencies:"
- elog " x11-misc/xdotool (enables autotype/autofill)"
- fi
-
- elog "Some systems may experience issues with copy and paste operations."
- elog "If you encounter this, please install x11-misc/xsel."
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}