summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-01 03:29:43 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:53:50 +0100
commit994a1edef26bdd95fc4ed07865d85f7fd4ad3c3d (patch)
treefb954cf7fef18cbfdf050564d94875d0d2203e10 /app-admin/keepass
parentapp-admin/ccze: eutils--, sort inherit (diff)
downloadgentoo-994a1edef26bdd95fc4ed07865d85f7fd4ad3c3d.tar.gz
gentoo-994a1edef26bdd95fc4ed07865d85f7fd4ad3c3d.tar.bz2
gentoo-994a1edef26bdd95fc4ed07865d85f7fd4ad3c3d.zip
app-admin/keepass: BDEPEND, eutils--, optfeature++, wrapper++
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin/keepass')
-rw-r--r--app-admin/keepass/keepass-2.46.ebuild20
-rw-r--r--app-admin/keepass/keepass-2.47.ebuild18
2 files changed, 15 insertions, 23 deletions
diff --git a/app-admin/keepass/keepass-2.46.ebuild b/app-admin/keepass/keepass-2.46.ebuild
index a42724fe8584..550a4da96f43 100644
--- a/app-admin/keepass/keepass-2.46.ebuild
+++ b/app-admin/keepass/keepass-2.46.ebuild
@@ -1,29 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit desktop eutils xdg-utils
+inherit desktop optfeature wrapper xdg-utils
MY_PN="KeePass"
DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
HOMEPAGE="https://keepass.info/"
SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
+S="${WORKDIR}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="aot"
-COMMON_DEPEND="dev-lang/mono"
-DEPEND="${COMMON_DEPEND}
- app-arch/unzip
-"
-RDEPEND="${COMMON_DEPEND}
+BDEPEND="app-arch/unzip"
+DEPEND="dev-lang/mono"
+RDEPEND="
+ ${DEPEND}
dev-dotnet/libgdiplus[cairo]
"
-S="${WORKDIR}"
PATCHES=( "${FILESDIR}/${PN}-2.36-xsl-path-detection.patch" )
# bug #687052
@@ -101,10 +100,7 @@ pkg_postinst() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
- if ! has_version x11-misc/xdotool ; then
- elog "Optional dependencies:"
- elog " x11-misc/xdotool (enables autotype/autofill)"
- fi
+ optfeature "enables autotype/autofill" x11-misc/xdotool
elog "Some systems may experience issues with copy and paste operations."
elog "If you encounter this, please install x11-misc/xsel."
diff --git a/app-admin/keepass/keepass-2.47.ebuild b/app-admin/keepass/keepass-2.47.ebuild
index af7035cf7b4b..850250d93e2c 100644
--- a/app-admin/keepass/keepass-2.47.ebuild
+++ b/app-admin/keepass/keepass-2.47.ebuild
@@ -3,27 +3,26 @@
EAPI=7
-inherit desktop eutils xdg-utils
+inherit desktop optfeature wrapper xdg-utils
MY_PN="KeePass"
DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
HOMEPAGE="https://keepass.info/"
SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
+S="${WORKDIR}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="aot"
-COMMON_DEPEND="dev-lang/mono"
-DEPEND="${COMMON_DEPEND}
- app-arch/unzip
-"
-RDEPEND="${COMMON_DEPEND}
+BDEPEND="app-arch/unzip"
+DEPEND="dev-lang/mono"
+RDEPEND="
+ ${DEPEND}
dev-dotnet/libgdiplus[cairo]
"
-S="${WORKDIR}"
PATCHES=( "${FILESDIR}/${PN}-2.36-xsl-path-detection.patch" )
# bug #687052
@@ -101,10 +100,7 @@ pkg_postinst() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
- if ! has_version x11-misc/xdotool ; then
- elog "Optional dependencies:"
- elog " x11-misc/xdotool (enables autotype/autofill)"
- fi
+ optfeature "enables autotype/autofill" x11-misc/xdotool
elog "Some systems may experience issues with copy and paste operations."
elog "If you encounter this, please install x11-misc/xsel."