summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-01-14 20:59:13 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-01-14 22:15:05 +0100
commit4594801b80c7d446b4f4e94a52260360648af605 (patch)
tree6037aa5b26340ba255b061de2eba624598415b43 /app-admin/kpcli/kpcli-3.1.ebuild
parentnet-analyzer/nagios-core: remove the rest of the unused files. (diff)
downloadgentoo-4594801b80c7d446b4f4e94a52260360648af605.tar.gz
gentoo-4594801b80c7d446b4f4e94a52260360648af605.tar.bz2
gentoo-4594801b80c7d446b4f4e94a52260360648af605.zip
app-admin/kpcli: Version bump, bug 601442
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin/kpcli/kpcli-3.1.ebuild')
-rw-r--r--app-admin/kpcli/kpcli-3.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-admin/kpcli/kpcli-3.1.ebuild b/app-admin/kpcli/kpcli-3.1.ebuild
new file mode 100644
index 000000000000..79c8a75613bc
--- /dev/null
+++ b/app-admin/kpcli/kpcli-3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A command line interface to KeePass database files"
+HOMEPAGE="http://kpcli.sourceforge.net"
+SRC_URI="http://downloads.sourceforge.net/project/kpcli/${P}.pl"
+
+LICENSE="|| ( Artistic GPL-1+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+DEPEND=""
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Clone
+ dev-perl/Crypt-Rijndael
+ dev-perl/TermReadKey
+ dev-perl/Sort-Naturally
+ dev-perl/Term-ShellUI
+ >=dev-perl/File-KeePass-0.30.0
+ virtual/perl-File-Spec
+ virtual/perl-Getopt-Long
+ virtual/perl-Digest-MD5
+ virtual/perl-Digest-SHA
+ virtual/perl-Data-Dumper
+ virtual/perl-Term-ANSIColor
+ virtual/perl-Carp
+ X? (
+ dev-perl/Capture-Tiny
+ dev-perl/Clipboard
+ )
+"
+
+src_unpack() {
+ mkdir "${S}" || die
+ cp "${DISTDIR}/${P}.pl" "${S}/${PN}" || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ dobin kpcli
+}