summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <tmozes@sygic.com>2018-05-14 14:57:24 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-14 15:45:50 +0200
commitc3679a6c2f1a696faa07d90358af73c7a997ff01 (patch)
tree87e2f115613e6c93b0251ae72ffc8bb4a804e428 /app-admin/logstash-bin
parentapp-admin/logstash-bin: bump to 5.6.9 (diff)
downloadgentoo-c3679a6c2f1a696faa07d90358af73c7a997ff01.tar.gz
gentoo-c3679a6c2f1a696faa07d90358af73c7a997ff01.tar.bz2
gentoo-c3679a6c2f1a696faa07d90358af73c7a997ff01.zip
app-admin/logstash-bin: bump to 6.2.4
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'app-admin/logstash-bin')
-rw-r--r--app-admin/logstash-bin/Manifest1
-rw-r--r--app-admin/logstash-bin/logstash-bin-6.2.4.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-admin/logstash-bin/Manifest b/app-admin/logstash-bin/Manifest
index 0a294aea4733..c016d3c9f63e 100644
--- a/app-admin/logstash-bin/Manifest
+++ b/app-admin/logstash-bin/Manifest
@@ -3,3 +3,4 @@ DIST logstash-5.6.9.zip 108563466 BLAKE2B 9225b823ac1f746481b34894c181aedabb0e69
DIST logstash-6.0.1.zip 116215793 BLAKE2B 676810b9cd62f578e31e1d63d4aae8c920590905a7344434d5e14607bab0e3ce59e2740e6839491f44ce769b24330a7a060174dcb5e6cb9cf51a31d165ba990b SHA512 395e4e2ff199d9ffc5156901d6ba6ab17771ab8f8859acede74567b2294e2d7ee2a6693e79f7b3e82c8d5c1959ad259bfb22e7992670cdcd3b73c7b72a635a31
DIST logstash-6.1.1.zip 116335093 BLAKE2B e7a990c2ea0eb3ec7de714f038765817c76eaf9e6cef0e55106f1f1aca406ec95d6be779f24c1fa28e096b51feeef968cb31f416f99c85c2f45d798bb74aadf7 SHA512 a2a420169dff31f3d5d65628a9d1eaad930a8e544fc4e986e3671ffeea3a1d03c8f77f8b51568a0da082588a843568fb7aefe29c1c90365882f429f9536f9240
DIST logstash-6.2.2.zip 146093122 BLAKE2B 0bd01673bb030593a944ecdd859ff0f44d8732f3ffef2b45b38798124c9caa547f625ae9c85300500683bac149b6ca4b9976bd0769fa0684989d40aa452a3584 SHA512 eb67b1fbe2530e4b24252a03aca572a41188e119cbf4a88267795782b347155f2e20405add6626585688fa6ed9d38fa463a0818fccd12612285950904dbd0cad
+DIST logstash-6.2.4.zip 153969993 BLAKE2B 989f631484be14014b8230e09fa049a0e470078fed938f2df55134a27d5f4f2d8670187126d32c4933b77b496a6ed96e12d180922c2c318c67fb3dbeec5a5a3b SHA512 65f6e5accc4441cb930e5c45723edeea54ba034a25680ca34114296af5a2c456d4152f9b38469475e600fce27a27b0d9c1d206039d12f2ec9cfeb02942a5c189
diff --git a/app-admin/logstash-bin/logstash-bin-6.2.4.ebuild b/app-admin/logstash-bin/logstash-bin-6.2.4.ebuild
new file mode 100644
index 000000000000..d1ce6cfb92d7
--- /dev/null
+++ b/app-admin/logstash-bin/logstash-bin-6.2.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-pkg-2 user
+
+MY_PN="${PN%-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for managing events and logs"
+HOMEPAGE="https://www.elastic.co/products/logstash"
+SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}.zip"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"
+
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/jre:1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /var/lib/${MY_PN} ${MY_PN}
+}
+
+src_install() {
+ keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
+ keepdir "/var/lib/${MY_PN}"
+ keepdir "/var/log/${MY_PN}"
+
+ insinto "/usr/share/${MY_PN}"
+ newins "${FILESDIR}/agent.conf.sample" agent.conf
+
+ rm -v config/startup.options || die
+ insinto /etc/${MY_PN}
+ doins -r config/.
+ rm -rv config data || die
+
+ insinto "/opt/${MY_PN}"
+ doins -r .
+ fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby" "/opt/${MY_PN}/bin/logstash-plugin"
+
+ newconfd "${FILESDIR}/${MY_PN}.confd-r1" "${MY_PN}"
+ newinitd "${FILESDIR}/${MY_PN}.initd-r1" "${MY_PN}"
+
+ insinto /usr/share/eselect/modules
+ doins "${FILESDIR}"/logstash-plugin.eselect
+}
+
+pkg_postinst() {
+ ewarn "The default pidfile directory has been changed from /run/logstash to /run."
+ ewarn "Please ensure any running logstash processes are shut down cleanly."
+ ewarn
+ ewarn "The default data directory has been moved from /opt/logstash/data to"
+ ewarn "/var/lib/logstash/data. Please check and move its contents as necessary."
+ ewarn
+ ewarn "Self installed plugins are removed during Logstash upgrades (Bug #622602)"
+ ewarn "Install the plugins via eselect module that will automatically re-install"
+ ewarn "all self installed plugins after Logstash upgrades."
+ elog
+ elog "Installing plugins:"
+ elog "eselect logstash-plugin install logstash-output-gelf"
+ elog
+
+ elog "Reinstalling self installed plugins (installed via eselect module):"
+ eselect logstash-plugin reinstall
+
+ elog
+ elog "Sample configuration:"
+ elog "${EROOT%/}/usr/share/${MY_PN}"
+}