summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-04-18 14:51:31 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-04-18 14:52:00 -0500
commitf8091861b941bf1130455fcdd5a806ec37d94cc1 (patch)
treeac4699632635feca64b01eb5574b04b0fb234ead /app-admin/mcollective
parentdev-libs/leatherman: 1.4.1 bup (diff)
downloadgentoo-f8091861b941bf1130455fcdd5a806ec37d94cc1.tar.gz
gentoo-f8091861b941bf1130455fcdd5a806ec37d94cc1.tar.bz2
gentoo-f8091861b941bf1130455fcdd5a806ec37d94cc1.zip
app-admin/mcollective: 2.12.1 bup
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'app-admin/mcollective')
-rw-r--r--app-admin/mcollective/Manifest1
-rw-r--r--app-admin/mcollective/mcollective-2.12.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-admin/mcollective/Manifest b/app-admin/mcollective/Manifest
index ec8363566f33..abc9f6a53fc5 100644
--- a/app-admin/mcollective/Manifest
+++ b/app-admin/mcollective/Manifest
@@ -1,2 +1,3 @@
DIST mcollective-2.11.4.tar.gz 1517194 BLAKE2B 8723d433e4b8e07b4aecd8c9d13c322ba3e3b6cb7153dbcbbc2e2463fe0ddf48c7b1c1d659e8a28278bb2fa4ec6b3da2f148117b3633b8148f9ba5a0aaabc4b4 SHA512 56af0a8b64ff75351f3448396f8a7cbba603869cdbfa7a97dde5a820e2e287c84e410a77469a3ce01f398858f5c6570c9e3542e372eaa00e3f54e68e3c1ce63b
DIST mcollective-2.12.0.tar.gz 1517498 BLAKE2B 0395cf027ad09e493387d6722112871ebd58def45a5a333dac801c643b989d0bb209489806123bb15a557fb6d690e0084dda2799512079ac1a599ddc664189b4 SHA512 ca3e3c6d58f7887e9564fce2ecb05b3c105f58401761082e7e7da5235166d722be9d3dc871cb8de14b7c9126fbc6e63f968c5cd1fd65701347323398fb1c56fd
+DIST mcollective-2.12.1.tar.gz 1517946 BLAKE2B 785acc53a4854f47caebe1d6a5f9cc850c3c33fd21e1b6e57d0d9761b2a7a3bbab2f2df398aa5344d90bc11397a545c8663d60ff3b2f6ff835fdc619d874928e SHA512 2398fb0202d8d5669a6efa81d96a87ee7e9221c1bc1b2e5be1917f2fec2527879b34be8df8c3052acf0ed58074b2da185f0837889d9300bde190bc95e8237d9a
diff --git a/app-admin/mcollective/mcollective-2.12.1.ebuild b/app-admin/mcollective/mcollective-2.12.1.ebuild
new file mode 100644
index 000000000000..d916d675849e
--- /dev/null
+++ b/app-admin/mcollective/mcollective-2.12.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="https://docs.puppet.com/mcollective/"
+SRC_URI="https://github.com/puppetlabs/marionette-collective/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/all/marionette-collective-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND=">=dev-ruby/stomp-1.4.4"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ cd "marionette-collective-${PV}"
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ use client && dosbin bin/mco
+ dosbin bin/mcollectived
+ if use doc ; then
+ dohtml -r doc/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ "${D}"/etc/mcollective/${cfg%%.dist} || die "sed failed"
+ done
+ insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] https://activemq.apache.org/"
+ einfo "[2] https://code.google.com/p/mcollective/wiki/GettingStarted"
+}