summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2018-11-15 14:50:32 -0800
committerPatrick McLean <chutzpah@gentoo.org>2018-11-15 14:52:08 -0800
commite89960b35cf778df12786199f79b7634746de3ec (patch)
tree1a301e7c499e93aa5000ee95b5af97c072d5f772 /app-admin/metalog
parentnet-vpn/wireguard: version bump (diff)
downloadgentoo-e89960b35cf778df12786199f79b7634746de3ec.tar.gz
gentoo-e89960b35cf778df12786199f79b7634746de3ec.tar.bz2
gentoo-e89960b35cf778df12786199f79b7634746de3ec.zip
app-admin/metalog: Version bump to 20181125 (bug #664344)
Update HOMEPAGE to GitHub site Closes: https://bugs.gentoo.org/664344 Closes: https://bugs.gentoo.org/669694 Bug: https://bugs.gentoo.org/210711 Bug: https://bugs.gentoo.org/670757 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-admin/metalog')
-rw-r--r--app-admin/metalog/Manifest1
-rw-r--r--app-admin/metalog/files/metalog.initd-r128
-rw-r--r--app-admin/metalog/metalog-20181125.ebuild64
3 files changed, 93 insertions, 0 deletions
diff --git a/app-admin/metalog/Manifest b/app-admin/metalog/Manifest
index f5591a27d987..3f1adee6f9a7 100644
--- a/app-admin/metalog/Manifest
+++ b/app-admin/metalog/Manifest
@@ -1 +1,2 @@
+DIST metalog-20181125.tar.gz 39472 BLAKE2B 64d90835d50c7cb10ab2bf2708d00189b9f8cb56438c29d5c445c5527cce030f918ba74f83cdcd54017f04fe2a8ab30e5631bcdf6681e56c311f8069981a9b5c SHA512 4b187a29b9e25a0f762f929c6993fa6e49ead470916a43a0dfbf16720a1a633121357d2f152bf4cdcd71c016aa4fc8fd6cffb35249abd430fbbf66651986bc4b
DIST metalog-3.tar.xz 360784 BLAKE2B 951841d423769cd97e14985e15d5a2499ca351e082c0effe28dc16d46db91235b7ef0448fe32d38b2ed5b53011d04b3375dc87c2a859c49bede2ae177ec16954 SHA512 2ac614bb85fe466308c4ced0842fdab5f056eda60e892189a8220719f1e06a72fce3c76842a2ac8c63a6808c20d8b7a7d8676896e14f7f54e40630ecbd21e289
diff --git a/app-admin/metalog/files/metalog.initd-r1 b/app-admin/metalog/files/metalog.initd-r1
new file mode 100644
index 000000000000..bb947bdadf8d
--- /dev/null
+++ b/app-admin/metalog/files/metalog.initd-r1
@@ -0,0 +1,28 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+pidfile="${PIDFILE:-/run/metalog.pid}"
+command="/usr/sbin/metalog"
+command_args="--pidfile=${pidfile} --daemonize ${METALOG_OPTS}"
+
+extra_started_commands="buffer unbuffer"
+
+depend() {
+ need localmount
+ use clock hostname
+ after bootmisc
+ provide logger
+}
+
+buffer() {
+ ebegin "Enabling log buffering"
+ start-stop-daemon --exec "${command}" --signal USR2 --pidfile "${pidfile}"
+ eend ${?}
+}
+
+unbuffer() {
+ ebegin "Disabling log buffering"
+ start-stop-daemon --exec "${command}" --signal USR1 --pidfile "${pidfile}"
+ eend ${?}
+}
diff --git a/app-admin/metalog/metalog-20181125.ebuild b/app-admin/metalog/metalog-20181125.ebuild
new file mode 100644
index 000000000000..9440d45f8e5e
--- /dev/null
+++ b/app-admin/metalog/metalog-20181125.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools systemd
+
+DESCRIPTION="A highly configurable replacement for syslogd/klogd"
+HOMEPAGE="https://github.com/hvisage/metalog"
+SRC_URI="https://github.com/hvisage/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="unicode"
+
+RDEPEND=">=dev-libs/libpcre-3.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9-metalog-conf.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with unicode)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README NEWS metalog.conf
+
+ into /
+ dosbin "${FILESDIR}"/consolelog.sh
+
+ newinitd "${FILESDIR}"/metalog.initd-r1 metalog
+ newconfd "${FILESDIR}"/metalog.confd metalog
+ systemd_newunit "${FILESDIR}/${PN}.service-r1" "${PN}.service"
+}
+
+pkg_preinst() {
+ if [[ -d "${ROOT}"/etc/metalog ]] && [[ ! -e "${ROOT}"/etc/metalog.conf ]] ; then
+ mv -f "${ROOT}"/etc/metalog/metalog.conf "${ROOT}"/etc/metalog.conf
+ rmdir "${ROOT}"/etc/metalog
+ export MOVED_METALOG_CONF=true
+ else
+ export MOVED_METALOG_CONF=false
+ fi
+}
+
+pkg_postinst() {
+ if ${MOVED_METALOG_CONF} ; then
+ ewarn "The default metalog.conf file has been moved"
+ ewarn "from /etc/metalog/metalog.conf to just"
+ ewarn "/etc/metalog.conf. If you had a standard"
+ ewarn "setup, the file has been moved for you."
+ fi
+}