summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2017-02-06 17:08:41 +0100
committerUltrabug <ultrabug@gentoo.org>2017-02-06 17:09:53 +0100
commit868f3223ff0975e49086b260ae4d05359e00ad67 (patch)
tree05ed04964e5b56a342e0d9448023b4f9815e8287 /app-admin/mongo-tools/mongo-tools-3.2.12.ebuild
parentdev-util/jenkins-bin: add 2.32.2 lts version, fixing bug 606364 (diff)
downloadgentoo-868f3223ff0975e49086b260ae4d05359e00ad67.tar.gz
gentoo-868f3223ff0975e49086b260ae4d05359e00ad67.tar.bz2
gentoo-868f3223ff0975e49086b260ae4d05359e00ad67.zip
app-admin/mongo-tools: version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin/mongo-tools/mongo-tools-3.2.12.ebuild')
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.2.12.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/mongo-tools-3.2.12.ebuild b/app-admin/mongo-tools/mongo-tools-3.2.12.ebuild
new file mode 100644
index 000000000000..f43e57c21823
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.2.12.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="http://www.mongodb.org"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sasl ssl"
+
+# Maintainer note:
+# openssl DEPEND constraint, see:
+# https://github.com/mongodb/mongo-tools/issues/11
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+ dev-lang/go:=
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e 's|go build .*|go build -o "bin/$i" -tags "$tags" "$i/main/$i.go"|g' -i build.sh || die
+
+ # ensure we use bash wrt #582906
+ sed -e 's@/bin/sh@/bin/bash@g' -i build.sh || die
+
+ epatch "${FILESDIR}/${PN}-3.2.10-pie.patch"
+}
+
+src_compile() {
+ local myconf
+
+ if use sasl; then
+ myconf="${myconf} sasl"
+ fi
+
+ if use ssl; then
+ myconf="${myconf} ssl"
+ fi
+
+ ./build.sh ${myconf} || die "build failed"
+}
+
+src_install() {
+ dobin bin/*
+}