summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2021-08-06 10:21:23 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2021-08-19 18:38:10 +0200
commitd0566d4248b7ee89816bfc8c7990849fb71ec26c (patch)
tree33448618a7255792e4551616bb604a561257eeaa /app-admin/mongo-tools
parentdev-db/mongodb: bump to 4.4.8 (diff)
downloadgentoo-d0566d4248b7ee89816bfc8c7990849fb71ec26c.tar.gz
gentoo-d0566d4248b7ee89816bfc8c7990849fb71ec26c.tar.bz2
gentoo-d0566d4248b7ee89816bfc8c7990849fb71ec26c.zip
app-admin/mongo-tools: bump to 4.2.15
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'app-admin/mongo-tools')
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-4.2.15.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index f88439232ef2..0d6fd8627a5a 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -3,3 +3,4 @@ DIST mongo-tools-100.2.1.tar.gz 27447213 BLAKE2B 9db242b632cf9d15960e216c238ad13
DIST mongo-tools-100.3.0.tar.gz 27514743 BLAKE2B 4b64c1d42679f5297ca0065b4e5e094a7c5f5bf7082a727b7c49e1b3b3af563e8f4055e041a696ea3e94ad62a3f280ec3f02d8b102df6f68a561b99d8a80b565 SHA512 415cf1b3a1015bab7c507cd7af969d7b8de249b8692fb93593793e9881290aaab827649fc59850bc905a50ee003d23116b6595979e3ca48dfcf1e6c5c864b5a0
DIST mongo-tools-4.2.11.tar.gz 15028877 BLAKE2B 8397ddfa553880680dabb3ca41801117431c75e9cf19c6145373b73c6da15b2be61e8673cec851872a0c481b221ac40e222754f9155c45f8a3e681e59272de6c SHA512 b1e9812890447f2ad1ed96ea5a70e8bb16efdaea37224249c531a3adda559b789a392b9818711147d28df412d7a2e2a992bc13fdcd595e50e66eb7fbd8c32bd5
DIST mongo-tools-4.2.12.tar.gz 15029039 BLAKE2B c2c87f6b329c4d094739fe215221fe507d2c685c4c56757b692e8f2de7a904f47fd92affcc9bbe227472efc09bdc97da78881b6ec2dbb03f79a34c42a3068ab3 SHA512 05cfef279c78ff1e929ccf47bee99a87cad70ede05bdac3f9226dc1e0c2688845233e51da69a2bb018d20b6f3ca4ae5301fb4f609e19f17636b4e5ac04fedb0f
+DIST mongo-tools-4.2.15.tar.gz 15028734 BLAKE2B 7479c5d0d9b6051f51e563f53a5c704a69dc3719d9417b216bcc1a65220d0ab2c9441fd24d8ac8e5b1600766797ef102df07ebfd946ee60949d3287673dfbaaf SHA512 f613ab61a4cf029548aa0e5623fef3798642ced791bf52f229e7d14d31de9472bfc3c8bfb3fa7b4542555a17c79ff9a514480c674cb3e45fb99c4f1745fdb9f0
diff --git a/app-admin/mongo-tools/mongo-tools-4.2.15.ebuild b/app-admin/mongo-tools/mongo-tools-4.2.15.ebuild
new file mode 100644
index 000000000000..1c622b0ee6a7
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-4.2.15.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.com"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="sasl ssl"
+
+DEPEND="dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+EGO_PN="github.com/mongodb/mongo-tools"
+S="${WORKDIR}/src/${EGO_PN}"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv ${MY_P} "${S}" || die
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ # build pie to avoid text relocations wrt #582854
+ local buildmode="pie"
+
+ # skip on ppc64 wrt #610984
+ if use ppc64; then
+ buildmode="default"
+ fi
+
+ mkdir -p bin || die
+ for i in bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop mongoreplay; do
+ echo "Building $i"
+ GO111MODULE='off' GOROOT="$(go env GOROOT)" GOPATH="${WORKDIR}" go build -buildmode="${buildmode}" -o "bin/$i" \
+ -ldflags "-X ${EGO_PN}/common/options.VersionStr=${PV}" --tags "${myconf[*]}" "$i/main/$i.go" || die
+ done
+}
+
+src_install() {
+ dobin bin/*
+}