summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-01-03 13:44:19 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-01-03 14:23:11 +0100
commitd5c1189616f7a985ea9727ebc0dc386ec35fe3ca (patch)
treee4a126887cef0de9d9742b1b8956e2e9293b759b /app-admin/packagekit-base
parentapp-admin/packagekit: version bump to 1.0.11 (diff)
downloadgentoo-d5c1189616f7a985ea9727ebc0dc386ec35fe3ca.tar.gz
gentoo-d5c1189616f7a985ea9727ebc0dc386ec35fe3ca.tar.bz2
gentoo-d5c1189616f7a985ea9727ebc0dc386ec35fe3ca.zip
app-admin/packagekit-base: version bump to 1.0.11, bug #565214
Also fixes bug #511934. Package-Manager: portage-2.2.26
Diffstat (limited to 'app-admin/packagekit-base')
-rw-r--r--app-admin/packagekit-base/Manifest1
-rw-r--r--app-admin/packagekit-base/packagekit-base-1.0.11.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/app-admin/packagekit-base/Manifest b/app-admin/packagekit-base/Manifest
index d5a10a1c6fd0..57f03a2720f0 100644
--- a/app-admin/packagekit-base/Manifest
+++ b/app-admin/packagekit-base/Manifest
@@ -1,2 +1,3 @@
DIST PackageKit-0.7.4.tar.xz 1493656 SHA256 4112c86d67afbbb9be5d3a706c63c537babbbe1f96e398ae306f5e5e02563a98 SHA512 a2cee60f499ec6c5359f3dc2eddda02cfb9c287f80a6b38aa1d9d87558ce5938ade87ab34f6cb1f9640749a0f19625b44c89f72dea5fbb0cbd5f34aec8dbb9f6 WHIRLPOOL 2827cb038c86164ae58021fafe9f2bbf21e69b5c63c4ef5e0f613806f5725f910af3d5aa51646fd258da9c91b81b086cf9560f66bf042e1cb6d1c25128f984b3
DIST PackageKit-0.8.15.tar.xz 1506084 SHA256 76aa44994d63b403b1f1154406539951502f5ab92624a8a7dedbeb5437ed0af5 SHA512 d6a1a4582212b02350b8a5ab8413346b0b33a49d329d3c5c4314e3db0c7c40b891d64d275c3acd8eafc45a59462b537cd031919027db2176502861271ce34a02 WHIRLPOOL bcc75e8a05b5616fbec1a2772af53ae51cf8c44a9feda4ca9cff4567f274aed62d3cf01751ab89834f423b77a74dcc1445c32390c323a46bb4340cde568760ce
+DIST PackageKit-1.0.11.tar.xz 1427404 SHA256 bbd27bbc77795394f25ab009fe1b3420e365541c99248b18bbaa2fa7f029eaf7 SHA512 9529037685f76e883a71ae502eabd83c3e1e8905f76cfe5e938760677f0224f8758bca59e139588aa06589bcca7a20f13dea0fe419022cb950c7a4c631237bce WHIRLPOOL 8d9bebf55acdff2096bb750bc1f3028cdbbb8e0fd09926de69c7e3dcbd7fe56a2908709be01633dd5a61df80afab05b28d8f424b1bbb79454f503cd03301e56a
diff --git a/app-admin/packagekit-base/packagekit-base-1.0.11.ebuild b/app-admin/packagekit-base/packagekit-base-1.0.11.ebuild
new file mode 100644
index 000000000000..ff02f783d7a7
--- /dev/null
+++ b/app-admin/packagekit-base/packagekit-base-1.0.11.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+# PackageKit supports 3.2+, but entropy and portage backends are untested
+# Future note: use --enable-python3
+PYTHON_COMPAT=( python2_7 )
+VALA_USE_DEPEND="vapigen"
+
+inherit bash-completion-r1 multilib nsplugins python-single-r1 systemd vala
+
+MY_PN="PackageKit"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Manage packages in a secure way using a cross-distro and cross-architecture API"
+HOMEPAGE="http://www.packagekit.org/"
+SRC_URI="http://www.freedesktop.org/software/${MY_PN}/releases/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/18"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="connman cron command-not-found +introspection networkmanager nsplugin entropy systemd test vala"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ vala? ( introspection )
+"
+
+# While not strictly needed, consolekit is the alternative to systemd-login
+# to get current session's user.
+CDEPEND="
+ >=app-shells/bash-completion-2
+ dev-db/sqlite:3
+ >=dev-libs/dbus-glib-0.74
+ >=dev-libs/glib-2.32.0:2[${PYTHON_USEDEP}]
+ >=sys-auth/polkit-0.98
+ >=sys-apps/dbus-1.3.0
+ ${PYTHON_DEPS}
+ connman? ( net-misc/connman )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.9[${PYTHON_USEDEP}] )
+ networkmanager? ( >=net-misc/networkmanager-0.6.4 )
+ nsplugin? (
+ >=dev-libs/nspr-4.8
+ x11-libs/cairo
+ >=x11-libs/gtk+-2.14.0:2
+ x11-libs/pango
+ )
+ systemd? ( >=sys-apps/systemd-204 )
+"
+DEPEND="${CDEPEND}
+ dev-libs/libxslt[${PYTHON_USEDEP}]
+ >=dev-util/gtk-doc-am-1.11
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+ nsplugin? ( >=net-misc/npapi-sdk-0.27 )
+ vala? ( $(vala_depend) )
+"
+RDEPEND="${CDEPEND}
+ >=app-portage/layman-2[${PYTHON_USEDEP}]
+ >=sys-apps/portage-2.2[${PYTHON_USEDEP}]
+ entropy? ( >=sys-apps/entropy-234[${PYTHON_USEDEP}] )
+ !systemd? ( sys-auth/consolekit )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="test"
+
+src_prepare() {
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ econf \
+ --disable-gstreamer-plugin \
+ --disable-gtk-doc \
+ --disable-gtk-module \
+ --disable-schemas-compile \
+ --disable-static \
+ --enable-bash-completion \
+ --enable-man-pages \
+ --enable-nls \
+ --enable-portage \
+ --localstatedir=/var \
+ $(use_enable command-not-found) \
+ $(use_enable connman) \
+ $(use_enable cron) \
+ $(use_enable entropy) \
+ $(use_enable introspection) \
+ $(use_enable networkmanager) \
+ $(use_enable nsplugin browser-plugin) \
+ $(use_enable systemd) \
+ $(use_enable test daemon-tests) \
+ $(use_enable vala) \
+ $(systemd_with_unitdir)
+ #$(use_enable test local)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files --all
+
+ dodoc AUTHORS ChangeLog MAINTAINERS NEWS README
+
+ if use nsplugin; then
+ dodir "/usr/$(get_libdir)/${PLUGINS_DIR}"
+ mv "${D}/usr/$(get_libdir)/mozilla/plugins"/* \
+ "${D}/usr/$(get_libdir)/${PLUGINS_DIR}/" || die
+ fi
+}