summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2018-09-19 10:36:01 -0500
committerBen Kohler <bkohler@gentoo.org>2018-09-19 10:37:44 -0500
commit948479c9430207150db5b8fc0618416f067860bf (patch)
tree25eb45cdfa038316eabd99d3a5d7636a0f67d0e5 /app-admin/ps_mem
parentdev-python/mistune: vump to 0.8.3 (diff)
downloadgentoo-948479c9430207150db5b8fc0618416f067860bf.tar.gz
gentoo-948479c9430207150db5b8fc0618416f067860bf.tar.bz2
gentoo-948479c9430207150db5b8fc0618416f067860bf.zip
app-admin/ps_mem: bump to 3.13 & fix license
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-admin/ps_mem')
-rw-r--r--app-admin/ps_mem/Manifest1
-rw-r--r--app-admin/ps_mem/ps_mem-3.13.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/ps_mem/Manifest b/app-admin/ps_mem/Manifest
index f25c8019bba7..5bf18609caad 100644
--- a/app-admin/ps_mem/Manifest
+++ b/app-admin/ps_mem/Manifest
@@ -1 +1,2 @@
DIST ps_mem-3.12.tar.gz 18074 BLAKE2B 98861120b09b3a25b29b5b461d50d8e6a8a684fe76685a7b032f769896dba4b8fa6cd1b1de2644488bf8b4568b960f2949eac2a72a6225cd19682a9c08803baa SHA512 aeba7573b651ffbe6bb263ecc257716cc91219aac232694a628b0e5b1e45235149d7dcf68f6b9ee669bd005adf68693cd09f32e378934690270b0b72c38abea4
+DIST ps_mem-3.13.tar.gz 18331 BLAKE2B a0689a98597e02a63cc83188e717421bf873b9202c0f524165ffc838fd438c539209c2f4e6561226bda8c6f85364707d29d13519d6d3e53a6d34cb39378d2de1 SHA512 bf5affaede5f052cc878d46ef81186511a1e8f5939cd7e8560ab2df9faf4dc31566cb4172d956cdcf1e6fc5586ba3458ba1011aee3720f6b7eeb3cf40b4f90dc
diff --git a/app-admin/ps_mem/ps_mem-3.13.ebuild b/app-admin/ps_mem/ps_mem-3.13.ebuild
new file mode 100644
index 000000000000..cedefddc1a27
--- /dev/null
+++ b/app-admin/ps_mem/ps_mem-3.13.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1 vcs-snapshot
+
+COMMIT="9f54e1aa3a87ec176ce8b71f02673e0d8293b344"
+
+DESCRIPTION="A utility to report core memory usage per program"
+HOMEPAGE="https://github.com/pixelb/${PN}"
+SRC_URI="https://github.com/pixelb/${PN}/tarball/${COMMIT} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}