summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-01-20 10:05:53 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-01-20 10:05:53 -0600
commit3821f500f7377f3597d6418501b603ed5af427f4 (patch)
tree7752359c881275dd9948c1644c978fbf65c3eda6 /app-admin/puppet-agent
parentsys-kernel/linux-firmware: remove old (diff)
downloadgentoo-3821f500f7377f3597d6418501b603ed5af427f4.tar.gz
gentoo-3821f500f7377f3597d6418501b603ed5af427f4.tar.bz2
gentoo-3821f500f7377f3597d6418501b603ed5af427f4.zip
app-admin/puppet-agent: bup
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.8.3.ebuild104
2 files changed, 106 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 003775021c20..2a3bd31d262d 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -2,3 +2,5 @@ DIST puppet-agent_1.7.2-1xenial_amd64.deb 13870204 SHA256 1d95b0d658b93acf09dc71
DIST puppet-agent_1.7.2-1xenial_i386.deb 15247880 SHA256 967e68ac690f8b15af7a9683bc8c3045acb4cf35f4950b3d2fdfdd8e4b3795e1 SHA512 01c0de5bd14d755222c85192cff48e8606b7e08ce75879824b885962e167ba6dcea29ecb3347e4985efe1a16fef36c1c2b7592acfe15396efbed5f643f81cbd6 WHIRLPOOL 0972b735237c963f203072d8fa2b6b08120dc1e333aabf73c78063bca4816d56d7d0f6d7fc48931c03bec9058d01eaef508ae4cce71bbd7367d6fca1bbd913c1
DIST puppet-agent_1.8.2-1xenial_amd64.deb 15179348 SHA256 5195af288ca014bcf65705c3fb83a1da8caf02eb1f431396380951480fb7e2dc SHA512 6093012994faaa3e7248c3e705e2dcb9269c85cfd4405c7ac66ab0adf3a547bc37ad3f5d44530514ed30a4edb01c01522eae1bced8d7ebade9ceb737ee600449 WHIRLPOOL 9905c00b16b12b75b331faf60c5ba3ad948a04db1ad4ef9b11aa413442fd464b836cc295cb4e0d85c34ebb3f97f470141cf207491fbeedb7964409ab75420f44
DIST puppet-agent_1.8.2-1xenial_i386.deb 16609778 SHA256 48d4588ae8c87a3a3e41c5c4e6159cba7bf6484578ce0761b4abd76854f7bdad SHA512 b96e239906e75773a22c37a28c3c794b7293cab1a970ba5067064b120e12e0a6f0b620f06dfb3cc5b83e9140467fa552aa05ea46a33f3fb8b489ac7790cb7734 WHIRLPOOL 6daf05a7ae5e50ecb922ffa260101cc62e64267fd40ca6dd8d684ab1b3760eb45a4f797f9644b7fb351f70a86e88d5c88cd1cc5dd4d68341912846466ba72257
+DIST puppet-agent_1.8.3-1xenial_amd64.deb 15531434 SHA256 2a468846e4b31f07dce9bbbf96c3fe06a528512cbc37bedc7ab44715a6833e94 SHA512 11958f51b75e012484f332b49d66bba225fdc19634f3972dfe5117ce7971d187bd7bca36dff079cd898e48c3545d560f34ee57a3acb710427154875d9d99100a WHIRLPOOL 895050da0f52a1e977d58802dcc5e5db11c331d5ad30732b1ac80e799d8b3312034efa800e3489b789cc40e9c156a5fe66050264d01a33c4a85e489a647b6324
+DIST puppet-agent_1.8.3-1xenial_i386.deb 16564720 SHA256 c2d5a1fd91941031b375b59f85f323a38977cc526b33e73f93eae50ee036fd65 SHA512 bb617c351ba26d431a6f0d6aa150c8888ee822feb63ebb56557586547e8afc9d387c5af6a6c59e6a885bc6ab195c89b3ea9317de74440abe6df76870c3dca345 WHIRLPOOL cdfd414d9113add49f9b60d5efcd5f16ce0f71a1bb094a4e98c31486b8ff86b1f9dbe1b5da0724358aa78d8f75c3aed9c8247a62595cdde92eab74519b9d06ef
diff --git a/app-admin/puppet-agent/puppet-agent-1.8.3.ebuild b/app-admin/puppet-agent/puppet-agent-1.8.3.ebuild
new file mode 100644
index 000000000000..af25c744880c
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.8.3.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/xenial/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1xenial"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/glibc
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.1.0 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="
+ /opt/puppetlabs/puppet
+ /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/mathn/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/io/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/dl/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/racc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/enc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/json/ext/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/rbconfig/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/digest/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/engines/*
+ /opt/puppetlabs/puppet/lib/virt-what/*
+ /opt/puppetlabs/puppet/lib/*
+ /opt/puppetlabs/puppet/bin/*"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/mcollective.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}