summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-07-18 15:45:47 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-07-18 15:51:49 -0500
commit43d30f80c04b111fa35f0ae21f151afa1fe17379 (patch)
tree244c27ab63df5db9c408fe13d823b174635fe063 /app-admin/puppet-agent
parentapp-admin/puppet: 5.2.3 bup (diff)
downloadgentoo-43d30f80c04b111fa35f0ae21f151afa1fe17379.tar.gz
gentoo-43d30f80c04b111fa35f0ae21f151afa1fe17379.tar.bz2
gentoo-43d30f80c04b111fa35f0ae21f151afa1fe17379.zip
app-admin/puppet-agent: 5.5.4 bup
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-5.5.4.ebuild85
2 files changed, 87 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index c8d50af815cb..6d3c13451af0 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -4,3 +4,5 @@ DIST puppet-agent_5.5.1-1stretch_amd64.deb 17325604 BLAKE2B 1fab815d5d238cb6a05d
DIST puppet-agent_5.5.1-1stretch_i386.deb 18063690 BLAKE2B ea7c7068e57da1249c1b1c7232e1af673840b0c8c7e5795574ffcb1861c68683ac9f21f8f4216272130b12a61bb8b324e49d6bf7f0c3d314857fd2591a7ad6ff SHA512 1a64616191a5143b150fe1d145ea786233ab763e87d5fe86bd1b3306fa73bab60d2f3d5c0bb7fcb6fe7c700a47a4c94c72eef1509732b18a5caf0fcd7f060602
DIST puppet-agent_5.5.3-1stretch_amd64.deb 17272112 BLAKE2B 5e052f837184b1d1dd5965ccb18e3a52dc88ea6ba85c0c3c5222ffe50e32e0a72a6f14274f5dd6c1bd63b3a160affa8a6b3399ac75e27d9cc2c267a1e1c0e89d SHA512 1629b3535b900081676647f64c17e3c0d23df38525d90d5f3993877d0749d18cf55f72fb20c47e20a63d18c2c7ad95cc0f179449c386ce3b8ec8a6d0f40243e7
DIST puppet-agent_5.5.3-1stretch_i386.deb 18189670 BLAKE2B a8791926a5ce08edad363670ab5269fcef208c3137db4126f33295fd7fdd447620578445eb0a9396e263fed8612981581cef0c5f6d3e51634722c01c79e2c9dc SHA512 83a1f472c4af97a48703ca61a00740fc7806155732bd488d3f9d757f969dca0a19cec014dad0bb5e6d8b5384d32c2d906ad0e8438efeeae5fdd39524cc11f6f8
+DIST puppet-agent_5.5.4-1stretch_amd64.deb 17273314 BLAKE2B e296cda8219deafe9b36039298823edb6007f42047e90e120fc16e941bb91c8d660e1a7f1341aa9463c67d4a5e05fbd8bf9c072a7768b0e885536efe5956115c SHA512 599aef07bb39b8d209e806ea1539157419de96376113ba88de6160525e96d6fa28f9865d7a89aff96698a0ff4e85ec474dd43ff4ea512b06a64c491c252cd973
+DIST puppet-agent_5.5.4-1stretch_i386.deb 18195740 BLAKE2B aa1e5b7030de4ec58a389a552c0d2c870875244f6a722c9b87d4aca28261f073b347476aaa313edd4f66fa07621a333c777a3a6b04228aa7d2f35391f4f84df8 SHA512 3e7346ccde7d3bc9e99bb38a2958c9ddda3dd4a5124ced21dc048df41566a0d9e6d9e5250f7c93433c02585fd83031292f8197a7c6537a1563dd6ebec464b979
diff --git a/app-admin/puppet-agent/puppet-agent-5.5.4.ebuild b/app-admin/puppet-agent/puppet-agent-5.5.4.ebuild
new file mode 100644
index 000000000000..5570060df99a
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-5.5.4.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/stretch/puppet5/${PN:0:1}/${PN}/${PN}_${PV}-1stretch"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/glibc
+ sys-libs/readline:0/7
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/mcollective.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym ../../opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym ../../opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym ../../opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+}