summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-15 01:03:13 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-15 01:03:13 -0500
commit4f172168c40062e480f9351d7eb9b46f88c7e7da (patch)
treed170d4458bd764c24c000ddeedccf118fc5aefdc /app-admin/puppet-agent
parentwww-servers/adsf: add 1.2.1 (diff)
downloadgentoo-4f172168c40062e480f9351d7eb9b46f88c7e7da.tar.gz
gentoo-4f172168c40062e480f9351d7eb9b46f88c7e7da.tar.bz2
gentoo-4f172168c40062e480f9351d7eb9b46f88c7e7da.zip
app-admin/puppet-agent: bump for bundled ossl
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.3.6.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 26de7c3c9462..91e32943c037 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -2,3 +2,5 @@ DIST puppet-agent_1.3.2-1wheezy_amd64.deb 18316012 SHA256 9d36e5d2902e8ffa9cb19a
DIST puppet-agent_1.3.2-1wheezy_i386.deb 18248404 SHA256 7e6570f592a712c342c192643cacfb74ca103efea26191cb8b8baa0f359b0fca SHA512 66a092cd7579af5aff89e3c45897c2f3d036fc2fb6e35be3492bdfb273d33c356e4d5ff53362d303eead6b3c53aeef9e82da1371b3555c94f67f11a65f0f5b6d WHIRLPOOL 8cf9f5ddad6815511f2c09d76e66d456aa15c68af0485dfda86a081fa3f6ecbdeeaf4815838c2f6113a65890532164bbba1fb12fb9607c5d1fa8c95d4df14217
DIST puppet-agent_1.3.4-1wheezy_amd64.deb 20088688 SHA256 d98026bc27d680c6d674889ddf76aab3da0f9122be3aaccfd4794c5193bf58af SHA512 1a11a7df1545c405f0cbcf6fa2b12a12d6f2091068706cc2be614b2aac4c2d1b8f92f8d6bb9721b5c9b7a30f27d087b585c4d9e41e9c966f526977bff1e39a91 WHIRLPOOL 619a00bdd175ad518a00c04410a09ed9502d768878f64810d434ef45bd41b2f0d695ea9fddb01a27b31989a90e47554b6a7577842f2762872601425b6801809f
DIST puppet-agent_1.3.4-1wheezy_i386.deb 19864590 SHA256 7eaf2264fc0ce048fd1fc604f384df8d601e8571e9f92fb1432bc2be73a24874 SHA512 2640a6b0daaa2a9c913a9411a7eb56914bb127610d2bf56100f9029dc94727f3c42df7c858924b22fc5ad03a9151d98a136c0c6d369501f3e38a9c179333d2ff WHIRLPOOL 88dbebd7c5217d7efc85c877bc1977c574e17ca544a59424b805cebcad637ed5762ebe37c13d82dc01cebcd1ef1259383143adff7a748c82241124b2007d5513
+DIST puppet-agent_1.3.6-1wheezy_amd64.deb 20097384 SHA256 47f04c848eff486660ba5ab4cc6c9340193ae0f9d703e0aba6094ccc7d15ec4f SHA512 a079f66bd0ff0b9535e037712ff4306ec16cc5303e1a19016a7ebb2d19f39eea1d91d758996d37e6d848cd0c1d8f047bcfad64550647de99de248071626a0845 WHIRLPOOL 42013e4abf062548b0349db3ebd628bfd887877462b3f24dbd47058bda59828c0f13f2f3bb8a7aace5d835faf3be0fbbaeb097c55c665aa71eec6d78881d71b7
+DIST puppet-agent_1.3.6-1wheezy_i386.deb 19873296 SHA256 aaf16cffcf33070eda0979025b72c87d1528bf017f65dadc333defe623190065 SHA512 4d6390c6f9fd3464029ae8bde02e5f7536de7ecb701bc50a7a4a24f50102fcd542448729259148bb62343ed44e4e5b41ced670aed7a8aa3897fa2f7729fff9db WHIRLPOOL 17f7231cd5c546aa8a104aadec07457abebb71cccc1f8f718e7e0e5544b46502979b3079e1d3931f58d3d2d4232eb2ac82e5ee2c49c0ed54e280ef515575b45f
diff --git a/app-admin/puppet-agent/puppet-agent-1.3.6.ebuild b/app-admin/puppet-agent/puppet-agent-1.3.6.ebuild
new file mode 100644
index 000000000000..a757b0a3a83d
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.3.6.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/wheezy/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1wheezy"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ sys-apps/dmidecode
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.1.0 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="
+ /opt/puppetlabs/puppet
+ /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/mathn/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/io/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/dl/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/racc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/enc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/json/ext/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/rbconfig/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/digest/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/engines/*
+ /opt/puppetlabs/puppet/lib/virt-what/*
+ /opt/puppetlabs/puppet/lib/*
+ /opt/puppetlabs/puppet/bin/*"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit "${FILESDIR}/puppet.service"
+ systemd_dounit "${FILESDIR}/mcollective.service"
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}