summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-11-02 10:06:19 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-11-02 10:08:42 -0500
commite704222a68056cd96d6d5ddda8a1717973b8a168 (patch)
treeb81ab9b916129110e4e34c0cace31bf8cf33acd3 /app-admin/puppet-agent
parentx11-drivers/nvidia-drivers: Copy nvml.h to the right path by Sven B. (bug #59... (diff)
downloadgentoo-e704222a68056cd96d6d5ddda8a1717973b8a168.tar.gz
gentoo-e704222a68056cd96d6d5ddda8a1717973b8a168.tar.bz2
gentoo-e704222a68056cd96d6d5ddda8a1717973b8a168.zip
app-admin/puppet-agent: bup
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.8.0.ebuild103
2 files changed, 105 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 7527811810ba..f29521f27944 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -1,2 +1,4 @@
DIST puppet-agent_1.7.1-1xenial_amd64.deb 13901688 SHA256 f9f0cedcb29f054064bc2b94e59c0a380ff01467c1c622e2b38f0957c7bea758 SHA512 018f99aab356cd597ecb1e94c22fd55f9e19e7ea0ced4b36c829ec9b45b7ba1c5188a3097cb0e837634a39eceb810b11e377b5c80decf94dd11b43b687f100ff WHIRLPOOL bc7ccbaf37e619fd89c0c6c4cb57db13a10cef5c030e48b25bb5d6e041a7a916af6d1d01f7fd4f7b8d047065e555aaebd1c3c81c6a91d17ca1bdda91e1dc48a5
DIST puppet-agent_1.7.1-1xenial_i386.deb 15252694 SHA256 0e2c94907bcd0174e5518a72eb91b4e66639ffa2829292044782658b7762fd19 SHA512 b1f85586848cff2b6790c93a320a7c8ee226d78dca14ddcf947e9d01c1b105b379cb0e044280640e95873e7abd31c3873d6e90117c249c314ae948bca36bad17 WHIRLPOOL b2460598fd12fdd565e6cc131a8e14d4eb411b233ce5125e436d09432fa5f9fca9d9065c515b53d0a26811a18d120cc0bcae0e9c848ed19820d89903d27340c3
+DIST puppet-agent_1.8.0-1xenial_amd64.deb 15184340 SHA256 9c00b0f7d1527927f0b95b744302c392ff24437d6de344dd259e0ed12c5fa22e SHA512 bd0c6571c9d66074f7e1e48c9766253684b6f164499566d0ebaf19e94a6ae7b8caf225cb93b668a3d9520fc4c8c0e3b44ef64661538eb5f9449d19d383149118 WHIRLPOOL 548b0adbae3ffc67bd6434e0cba60e7c87afa759400581df73f081b03802731a0ef0ba581d476d13559d264c2ce22bef7cafa0d7ce5fab381d75f3f0c7e98137
+DIST puppet-agent_1.8.0-1xenial_i386.deb 16607898 SHA256 407e8cfdf184a23f3813ea66bf53c3b4bfa7b2b7e1b8eb53e49bbd3266afd1b6 SHA512 3bbddfe85a8f66b48ad1f10d98ab12376df3d839d0bc8b8a3a00022ad3df8f3f3b8ebbf32a7a4bee3c4ba245a4e7da08f7adf7c817ce395527e247a6d4e68694 WHIRLPOOL 9aa1ad9bc3f7b161f939bdfdc979e05b3da543247d0260486806200afb18f03cb1a5f3fc012aad1c2d788e932a1aabc64fe547394b282c72dc7b6d247c912cd0
diff --git a/app-admin/puppet-agent/puppet-agent-1.8.0.ebuild b/app-admin/puppet-agent/puppet-agent-1.8.0.ebuild
new file mode 100644
index 000000000000..5d616911a0ac
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.8.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/xenial/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1xenial"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.1.0 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="
+ /opt/puppetlabs/puppet
+ /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/mathn/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/io/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/dl/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/racc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/enc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/json/ext/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/rbconfig/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/digest/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/engines/*
+ /opt/puppetlabs/puppet/lib/virt-what/*
+ /opt/puppetlabs/puppet/lib/*
+ /opt/puppetlabs/puppet/bin/*"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/mcollective.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}