summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-25 00:45:07 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-25 00:45:07 -0500
commitfe36d6a6ef8d49b796055cd5a921f60404e13cf5 (patch)
tree3497b35cfcfd4ae65d0099c1592c4065d25a01ab /app-admin/puppet-agent
parentsys-auth/keystone: py35 (diff)
downloadgentoo-fe36d6a6ef8d49b796055cd5a921f60404e13cf5.tar.gz
gentoo-fe36d6a6ef8d49b796055cd5a921f60404e13cf5.tar.bz2
gentoo-fe36d6a6ef8d49b796055cd5a921f60404e13cf5.zip
app-admin/puppet-agent: bup
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.4.1.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index e487dd7221b0..b3f023abb717 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -2,3 +2,5 @@ DIST puppet-agent_1.3.6-1wheezy_amd64.deb 20097384 SHA256 47f04c848eff486660ba5a
DIST puppet-agent_1.3.6-1wheezy_i386.deb 19873296 SHA256 aaf16cffcf33070eda0979025b72c87d1528bf017f65dadc333defe623190065 SHA512 4d6390c6f9fd3464029ae8bde02e5f7536de7ecb701bc50a7a4a24f50102fcd542448729259148bb62343ed44e4e5b41ced670aed7a8aa3897fa2f7729fff9db WHIRLPOOL 17f7231cd5c546aa8a104aadec07457abebb71cccc1f8f718e7e0e5544b46502979b3079e1d3931f58d3d2d4232eb2ac82e5ee2c49c0ed54e280ef515575b45f
DIST puppet-agent_1.4.0-1wheezy_amd64.deb 21367140 SHA256 322f3db0e1c2cebe675f6162411eecc9aec4e6a9d20daba4416ad914a7d562f0 SHA512 9d40ca518dfe5086f9fb738c971fed06b6f634f2069a0a10ae4ea4c1595db6c7122323dcbe1f871faed114acd1a3405146fb834fce964312391159b6e66edae5 WHIRLPOOL cf5f1649083e3224cffa5c1b16164e8cdb2a7fdc4756b97e12dfd6857e74e5923e04282d885ac963ef4fc386843e1014c489346836798eec1db5ed70d187a15e
DIST puppet-agent_1.4.0-1wheezy_i386.deb 21107662 SHA256 88adf39e5fd7dba87f497c348797207df1f3192228d8601de9cbd155d481c31f SHA512 6651bb55b7ab4db5ce738dfa8ff555d385c7ea5c3806e5e3a961afaf58fc8923e44264bbd33b920871a84ebaa8b7003374a269467fe13454f7f498c18ba3afec WHIRLPOOL bffdcf7cffc6bf6dcce925728ac032c2fd7e2e19641eef200b60b5ec3fd1e0b87b44a6fd43c001cec0b69d96f050243252a0a954240568344ddcdb481010a700
+DIST puppet-agent_1.4.1-1wheezy_amd64.deb 21371032 SHA256 bc73ca0bf9bf753f70c261f0884a19c94cf0d0f337d370af9e2424f563eed7f9 SHA512 5c99cbc1637992630152d8d5f9922ee38e78147cca04ef030ff0232bf729e5dddd607cc0f318a09e52bfb29d991ff7f111b564d8e173240cc1b0f039f34ad69b WHIRLPOOL c41bfad01fef8329b3ed599c1f5bc98b6e306bb7d0c2cd4ad85a2d3ddb97797828d794c3b0eeaab6650a80c2ba07b644e29ea914c494711be31abf8582e9f13f
+DIST puppet-agent_1.4.1-1wheezy_i386.deb 21109088 SHA256 a6ef8820dc6a96522da30bc9cac992a61e87d8c29a3908849455d8eb0ffeb725 SHA512 f9a62e8d71af1a466cc3ad2fcece79d300251dd936d97e2360580452de9f964b18316643e488b1dbe3ebd610cb58a6f19e5f70534a1cb42a016cc5719cd7b016 WHIRLPOOL 02d45b9260f71eeb94d7a7aa2da0a2491db6ab0d31bfc8afe37b5086d87503a090b850965ab2a339e7ac58c24aa277b985bec19b7d728e24ac7fe336fa5512cd
diff --git a/app-admin/puppet-agent/puppet-agent-1.4.1.ebuild b/app-admin/puppet-agent/puppet-agent-1.4.1.ebuild
new file mode 100644
index 000000000000..b449a7ad7524
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.4.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/wheezy/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1wheezy"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ sys-apps/dmidecode
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.1.0 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="
+ /opt/puppetlabs/puppet
+ /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/mathn/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/io/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/dl/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/racc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/enc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/json/ext/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/rbconfig/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/digest/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/engines/*
+ /opt/puppetlabs/puppet/lib/virt-what/*
+ /opt/puppetlabs/puppet/lib/*
+ /opt/puppetlabs/puppet/bin/*"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit "${FILESDIR}/puppet.service"
+ systemd_dounit "${FILESDIR}/mcollective.service"
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}