summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-01-22 18:40:01 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-01-22 18:59:01 -0600
commit695d721d1dcd80fb9aece54c53b773850b3cee33 (patch)
tree00d939d2530788f8178e0d726d365cd2617dc8eb /app-admin/puppet
parentdev-util/umockdev: Version bump to 0.17.6 (diff)
downloadgentoo-695d721d1dcd80fb9aece54c53b773850b3cee33.tar.gz
gentoo-695d721d1dcd80fb9aece54c53b773850b3cee33.tar.bz2
gentoo-695d721d1dcd80fb9aece54c53b773850b3cee33.zip
app-admin/puppet: 7.14.0 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/Manifest1
-rw-r--r--app-admin/puppet/puppet-7.14.0.ebuild127
2 files changed, 128 insertions, 0 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index 4575b948ab9c..44917937b201 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -1,3 +1,4 @@
DIST puppet-5.5.22.tar.gz 2998132 BLAKE2B 8662c89190d0904fe44ffeca1cf9a9ddca40d57ba6fb2d1e644ca353ceb55b1ca3a91416f1eef2975233c9c4498784e7d7280c111ea0cc070870cadc69341d99 SHA512 5332b084a63bdf244672cc4751022c84a1cc50d3f394a13bdcbccf7fcf4ebea67953e88957f23046608bf25e9182548449be824c18289cb2bf1e3ed29b40dc58
DIST puppet-7.12.0.tar.gz 2862376 BLAKE2B da0d3d05de8187492cbb14d98df0c7eef7fea5a2fdad0f41b687fcef20979d34c1d84513c4c7a504eb95934228b832e416aecb5f626fba20920df286fd403bcd SHA512 5df5b78d5e27ff64e49f440c6e3add7af1b58cd4da6ac5cd649dce012e830e349c2dbc27bf03d4668e2a10cec6628b2872457c7b6f7fe7a4f7cfbd6c8fe8ae2d
DIST puppet-7.13.1.tar.gz 2874201 BLAKE2B 663cae7ed82cd9daf2efe70564509f7abc73361df3558a81a99995f1667cedc0d7237644ff3bdfa857dc1239d9aaaeb9815d7b420c8c06ff3b1d7cd4f285b817 SHA512 f1cc3ce9c030ede1847c12c87411a29a785cf6219322e287a69577ccd08211bd485050aaa651941894d331d23927ce627b06aa73d060502ae2835aaab5c08570
+DIST puppet-7.14.0.tar.gz 2816077 BLAKE2B c4aacf7179208e801fad2aa384691e38ca4bd1329819d4ca15b7a3cf25c5787e8adef12c91d233c5adbc301ab77cdf9748f094a1904c78c62d6ac73dafb4a634 SHA512 36aaa9c8cce9d1c40e77eee1e3544c0b0c665bbfa3b8184401905d6f15c142be8490421af0dac57856849de343b288f67153c551db68f8cea9e0ed3ad251feb3
diff --git a/app-admin/puppet/puppet-7.14.0.ebuild b/app-admin/puppet/puppet-7.14.0.ebuild
new file mode 100644
index 000000000000..21df500a05a1
--- /dev/null
+++ b/app-admin/puppet/puppet-7.14.0.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="doc:all"
+RUBY_FAKEGEM_EXTRAINSTALL="locales"
+
+inherit ruby-fakegem systemd tmpfiles
+
+DESCRIPTION="A system automation and configuration management software"
+HOMEPAGE="https://puppet.com/"
+SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
+RESTRICT="test"
+
+ruby_add_rdepend "
+ dev-ruby/hiera
+ dev-ruby/json:=
+ dev-ruby/semantic_puppet
+ >=dev-ruby/facter-3.0.0
+ dev-ruby/concurrent-ruby
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl
+ dev-ruby/hocon"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )
+ test? (
+ dev-ruby/mocha
+ dev-ruby/rack
+ dev-ruby/rspec-its
+ )"
+# this should go in the above lists, but isn't because of test deps not being keyworded
+# dev-ruby/rspec-collection_matchers
+
+RDEPEND+=" ${RDEPEND}
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0
+ acct-user/puppet
+ acct-group/puppet"
+PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
+
+all_ruby_prepare() {
+ # Avoid spec that require unpackaged json-schema.
+ rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
+
+ # fix systemd path
+ eapply -p0 "${FILESDIR}/puppet-systemd.patch"
+
+ # Avoid specs that can only run in the puppet.git repository. This
+ # should be narrowed down to the specific specs.
+ rm spec/integration/parser/compiler_spec.rb || die
+
+ # Avoid failing spec that need further investigation.
+ rm spec/unit/module_tool/metadata_spec.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # systemd stuffs
+ systemd_dounit "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+
+ # tmpfiles stuff
+ newtmpfiles "${FILESDIR}/tmpfiles.d" "puppet.conf"
+
+ # openrc init stuff
+ newinitd "${FILESDIR}"/puppet.init-4.x puppet
+
+ keepdir /etc/puppetlabs/puppet/ssl
+
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+
+ fperms 0750 /var/lib/puppet
+
+ fperms 0750 /etc/puppetlabs
+ fperms 0750 /etc/puppetlabs/puppet
+ fperms 0750 /etc/puppetlabs/puppet/ssl
+ fowners -R :puppet /etc/puppetlabs
+ fowners -R :puppet /var/lib/puppet
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"
+ dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ tmpfiles_process puppet.conf
+
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Portage Puppet module with Gentoo-specific resources:"
+ elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog
+ elog "If updating from puppet 5 to 6, keep in mind that webrick (server/master)"
+ elog "suppert was removed for >=6.x, please migrate to puppetserver if you have"
+ elog "not already done so."
+ elog
+}