summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-15 09:26:28 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-15 09:26:28 +0200
commit82dbf699daa22c05bc8fccc59b58e83146869403 (patch)
treef8e15d043360b5469ee02d41a005a08f4e04e116 /app-admin/puppet
parentapp-emacs/puppet-mode: rename puppet-mode.el sitelisp file (diff)
downloadgentoo-82dbf699daa22c05bc8fccc59b58e83146869403.tar.gz
gentoo-82dbf699daa22c05bc8fccc59b58e83146869403.tar.bz2
gentoo-82dbf699daa22c05bc8fccc59b58e83146869403.zip
app-admin/puppet: depend on external puppet-mode for USE=emacs
Use the external app-emacs/puppet-mode which has improvements and bug fixes over the bundled version. Depend on a new enough version of puppet-mode to avoid file collisions. Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/puppet-4.10.4.ebuild15
-rw-r--r--app-admin/puppet/puppet-5.0.0.ebuild2
2 files changed, 3 insertions, 14 deletions
diff --git a/app-admin/puppet/puppet-4.10.4.ebuild b/app-admin/puppet/puppet-4.10.4.ebuild
index 632f5aeedbda..7ec0d6d305d6 100644
--- a/app-admin/puppet/puppet-4.10.4.ebuild
+++ b/app-admin/puppet/puppet-4.10.4.ebuild
@@ -7,7 +7,7 @@ USE_RUBY="ruby21 ruby22 ruby23"
#RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-inherit elisp-common xemacs-elisp-common eutils user ruby-fakegem versionator
+inherit xemacs-elisp-common eutils user ruby-fakegem versionator
DESCRIPTION="A system automation and configuration management software."
HOMEPAGE="http://puppetlabs.com/"
@@ -43,7 +43,6 @@ ruby_add_rdepend "
# )"
DEPEND+=" ${DEPEND}
- emacs? ( virtual/emacs )
xemacs? ( app-editors/xemacs )"
RDEPEND+=" ${RDEPEND}
rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
@@ -53,6 +52,7 @@ RDEPEND+=" ${RDEPEND}
)
vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
>=app-portage/eix-0.18.0"
+PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
SITEFILE="50${PN}-mode-gentoo.el"
@@ -102,10 +102,6 @@ all_ruby_prepare() {
}
all_ruby_compile() {
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el
- fi
-
if use xemacs ; then
# Create a separate version for xemacs to be able to install
# emacs and xemacs in parallel.
@@ -150,11 +146,6 @@ all_ruby_install() {
fowners -R :puppet /etc/puppetlabs
fowners -R :puppet /var/lib/puppet
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
if use xemacs ; then
xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
@@ -190,11 +181,9 @@ pkg_postinst() {
elog
fi
- use emacs && elisp-site-regen
use xemacs && xemacs-elisp-site-regen
}
pkg_postrm() {
- use emacs && elisp-site-regen
use xemacs && xemacs-elisp-site-regen
}
diff --git a/app-admin/puppet/puppet-5.0.0.ebuild b/app-admin/puppet/puppet-5.0.0.ebuild
index ba4233344665..6c3489f60386 100644
--- a/app-admin/puppet/puppet-5.0.0.ebuild
+++ b/app-admin/puppet/puppet-5.0.0.ebuild
@@ -51,7 +51,7 @@ RDEPEND+=" ${RDEPEND}
)
vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
>=app-portage/eix-0.18.0"
-PDEPEND="emacs? ( app-emacs/puppet-mode )"
+PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
pkg_setup() {
enewgroup puppet