summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2019-05-31 10:41:57 +0000
committerSven Wegener <swegener@gentoo.org>2019-05-31 10:41:57 +0000
commitcc3ab1d230c03ccb98a33830b777688c164159fa (patch)
tree76cd44e81fb7300a7923923512b26152dcdf58a1 /app-admin/puppet
parentdev-libs/kpathsea: Version bump (diff)
downloadgentoo-cc3ab1d230c03ccb98a33830b777688c164159fa.tar.gz
gentoo-cc3ab1d230c03ccb98a33830b777688c164159fa.tar.bz2
gentoo-cc3ab1d230c03ccb98a33830b777688c164159fa.zip
app-admin/puppet: Fix tests patch to apply
Signed-off-by: Sven Wegener <swegener@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/files/puppet-fix-tests-5.5.14.patch18
-rw-r--r--app-admin/puppet/puppet-5.5.14.ebuild2
2 files changed, 19 insertions, 1 deletions
diff --git a/app-admin/puppet/files/puppet-fix-tests-5.5.14.patch b/app-admin/puppet/files/puppet-fix-tests-5.5.14.patch
new file mode 100644
index 000000000000..09ffe07da1ae
--- /dev/null
+++ b/app-admin/puppet/files/puppet-fix-tests-5.5.14.patch
@@ -0,0 +1,18 @@
+--- puppet/spec/unit/network/http/api/indirected_routes_spec.rb
++++ puppet/spec/unit/network/http/api/indirected_routes_spec.rb
+@@ -142,15 +142,6 @@
+ handler.uri2indirection("GET", uri_escaped, params)
+ end
+
+- it "should not pass through an environment to check_authorization and fail if the environment is unknown" do
+- expect(handler).to receive(:check_authorization) do |_, _, arg|
+- expect(arg).not_to include(:environment)
+- end
+- expect(lambda { handler.uri2indirection("GET",
+- "#{master_url_prefix}/node/bar",
+- {:environment => 'bogus'}) }).to raise_error(not_found_error)
+- end
+-
+ it "should not URI unescape the indirection key as passed through to a call to check_authorization" do
+ expect(handler).to receive(:check_authorization).with(anything, anything, hash_including(environment: be_a(Puppet::Node::Environment).and(have_attributes(name: :env))))
+
diff --git a/app-admin/puppet/puppet-5.5.14.ebuild b/app-admin/puppet/puppet-5.5.14.ebuild
index 12914f0e266d..75759e0d00b6 100644
--- a/app-admin/puppet/puppet-5.5.14.ebuild
+++ b/app-admin/puppet/puppet-5.5.14.ebuild
@@ -66,7 +66,7 @@ all_ruby_prepare() {
rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
# can't be run within portage.
- epatch "${FILESDIR}/puppet-fix-tests-4.7.0.patch"
+ epatch "${FILESDIR}/puppet-fix-tests-5.5.14.patch"
# fix systemd path
epatch "${FILESDIR}/puppet-systemd.patch"