summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2018-05-15 20:37:04 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-16 10:17:43 +0200
commitdbce389e48b0996f21c14cd44a8492bcc5581f93 (patch)
tree4ea92a5a6931588128f68c073e24049cd1776342 /app-admin/qtpass
parentgames-engines/qtads-2.1.7-r1: fix build with GCC 7 (diff)
downloadgentoo-dbce389e48b0996f21c14cd44a8492bcc5581f93.tar.gz
gentoo-dbce389e48b0996f21c14cd44a8492bcc5581f93.tar.bz2
gentoo-dbce389e48b0996f21c14cd44a8492bcc5581f93.zip
app-admin/qtpass: 1.2.2 version bump
1. Sorted in alphabetical order eclasses, keywords. 2. Added USE-flag test. 3. Fixed dependencies and src_prepare section. 4. Fixed tests installation (patches are in upstream). 5. Added installation of appdata. 6. Added localization support (l10n eclass). Closes: https://bugs.gentoo.org/643526 Closes: https://bugs.gentoo.org/642956 Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6794
Diffstat (limited to 'app-admin/qtpass')
-rw-r--r--app-admin/qtpass/Manifest1
-rw-r--r--app-admin/qtpass/qtpass-1.2.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/app-admin/qtpass/Manifest b/app-admin/qtpass/Manifest
index 397410986fb2..0d1ae76af592 100644
--- a/app-admin/qtpass/Manifest
+++ b/app-admin/qtpass/Manifest
@@ -1 +1,2 @@
DIST qtpass-1.2.1.tar.gz 361147 BLAKE2B f46ce4362d4d3e0c0b0a425e5a40cf013181b899d5b1a2efc03cc5c4a3eca2d3ce1cdca78fdb95e8fecae23ffe56c01dbe65c9d07e2fff48934e995a710aac40 SHA512 3621a46aab5db5a41e80aea10bc6baf662510bcb249a1f56d33492aa66c824d9f018164f2d6a70256a7b3d59a9b73c4c8459b5d3fbe19886a607f8f0dc7410c1
+DIST qtpass-1.2.2.tar.gz 366601 BLAKE2B 7b06926465e7d7cbb837cf87b47a89b114b9ae9c508aa558695744c84a00a58a8922155eda3f91a6350354668b381381be757db07f201798a2ee25685e034871 SHA512 cb480357b161573054b752af25f20757057de5c5b2e55619e3fa594c5d9b63c7036b72c0ae7735f8ec197ac8aa43b7fdfbc836b29fbe4c85de8dc5d93ce7bbd2
diff --git a/app-admin/qtpass/qtpass-1.2.2.ebuild b/app-admin/qtpass/qtpass-1.2.2.ebuild
new file mode 100644
index 000000000000..e0c3748be47c
--- /dev/null
+++ b/app-admin/qtpass/qtpass-1.2.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="QtPass-${PV}"
+PLOCALES="ar_MA ca cs_CZ de_DE de_LU el_GR en_GB en_US es_ES fr_BE fr_FR fr_LU
+gl_ES he_IL hu_HU it_IT lb_LU nl_BE nl_NL pl_PL pt_PT ru_RU sv_SE zh_CN"
+
+inherit desktop l10n qmake-utils
+
+DESCRIPTION="multi-platform GUI for pass, the standard unix password manager"
+HOMEPAGE="https://qtpass.org/"
+SRC_URI="https://github.com/IJHack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="app-admin/pass
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[xcb]
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ net-misc/x11-ssh-askpass"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ dev-qt/qtsvg:5
+ test? ( dev-qt/qttest:5 )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md FAQ.md README.md )
+
+src_prepare() {
+ default
+
+ if ! use test ; then
+ sed -i '/SUBDIRS += src /s/tests //' \
+ qtpass.pro || die "sed for qtpass.pro failed"
+ fi
+
+ l10n_find_plocales_changes localization localization_ .ts
+}
+
+src_configure() {
+ eqmake5 PREFIX="${D}"/usr
+}
+
+src_compile() {
+ default
+
+ local lr
+ lr="$(qt5_get_bindir)"/lrelease
+ l10n_build() {
+ $lr localization/localization_"${1}".ts || die "lrelease ${1} failed"
+ }
+ l10n_for_each_locale_do l10n_build
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/"${PN}"/translations
+ doins localization/*.qm
+
+ doman "${PN}".1
+ insinto /usr/share/applications
+ doins "${PN}".desktop
+ newicon artwork/icon.png "${PN}"-icon.png
+ insinto /usr/share/appdata
+ doins qtpass.appdata.xml
+}