summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-12-21 15:46:05 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-12-21 15:46:32 -0600
commit2ec5d27e3a98b1e308c902bcc7e6998b4a80dbef (patch)
treeaeb7da9cdb9b532c48e62702ce6fdad6bc947f4c /app-admin/rasdaemon
parentdev-libs/libcgroup: remove older version (diff)
downloadgentoo-2ec5d27e3a98b1e308c902bcc7e6998b4a80dbef.tar.gz
gentoo-2ec5d27e3a98b1e308c902bcc7e6998b4a80dbef.tar.bz2
gentoo-2ec5d27e3a98b1e308c902bcc7e6998b4a80dbef.zip
app-admin/rasdaemon: 0.6.0 added as a replacement for mcelog
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'app-admin/rasdaemon')
-rw-r--r--app-admin/rasdaemon/Manifest1
-rw-r--r--app-admin/rasdaemon/metadata.xml18
-rw-r--r--app-admin/rasdaemon/rasdaemon-0.6.0.ebuild39
3 files changed, 58 insertions, 0 deletions
diff --git a/app-admin/rasdaemon/Manifest b/app-admin/rasdaemon/Manifest
new file mode 100644
index 000000000000..93bbf015df36
--- /dev/null
+++ b/app-admin/rasdaemon/Manifest
@@ -0,0 +1 @@
+DIST rasdaemon-0.6.0.tar.bz2 361721 BLAKE2B af992c810024df4f553727b4aff4f4f1d41cb3f7e458ac91916ccbac6815b6ade697f0c49bf1e072205c7f872cfc9c2f7223fe0d3f090064ffaa0bab002d4f67 SHA512 cb363ee9968dab10951077edea6558adc235c2ba1a57294ccf2d483c49af3366bcec0a5857fe2b475a5407de850f706c44bfe4d8a80bcfb53b1c7e2d101ba72f
diff --git a/app-admin/rasdaemon/metadata.xml b/app-admin/rasdaemon/metadata.xml
new file mode 100644
index 000000000000..2e59b91513af
--- /dev/null
+++ b/app-admin/rasdaemon/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Rasdaemon is a RAS (Reliability, Availability and Serviceability) logging tool.
+It currently records memory errors, using the EDAC tracing events.
+EDAC is drivers in the Linux kernel that handle detection of ECC errors
+from memory controllers for most chipsets on i386 and x86_64 architectures.
+EDAC drivers for other architectures like arm also exists.
+This userspace component consists of an init script which makes sure
+EDAC drivers and DIMM labels are loaded at system startup, as well as
+an utility for reporting current error counts from the EDAC sysfs files.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-admin/rasdaemon/rasdaemon-0.6.0.ebuild b/app-admin/rasdaemon/rasdaemon-0.6.0.ebuild
new file mode 100644
index 000000000000..7bb3e34c6e73
--- /dev/null
+++ b/app-admin/rasdaemon/rasdaemon-0.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+DESCRIPTION="Reliability, Availability and Serviceability logging tool"
+HOMEPAGE="http://www.infradead.org/~mchehab/rasdaemon/"
+SRC_URI="http://www.infradead.org/~mchehab/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+ sys-devel/gettext
+ dev-db/sqlite
+ sys-apps/dmidecode
+"
+
+src_configure() {
+ econf --enable-mce \
+ --enable-aer \
+ --enable-sqlite3 \
+ --enable-extlog \
+ --enable-abrt-report \
+ --enable-non-standard \
+ --enable-hisi-ns-decode \
+ --enable-arm
+}
+
+src_install() {
+ default
+ systemd_dounit misc/*.service
+}