summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-05-23 23:32:36 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-05-23 23:32:53 -0500
commite7e05995da72932bbe91c2b72d498ce86b862218 (patch)
tree836c670f75636dacc4596dc7211d94b013684403 /app-admin/rasdaemon
parentx11-misc/light-locker: bump to 1.9.0 (diff)
downloadgentoo-e7e05995da72932bbe91c2b72d498ce86b862218.tar.gz
gentoo-e7e05995da72932bbe91c2b72d498ce86b862218.tar.bz2
gentoo-e7e05995da72932bbe91c2b72d498ce86b862218.zip
app-admin/rasdaemon: we don't need sqlite
Thanks to Paul B. Henson <henson@acm.org> for the help Fixes: https://bugs.gentoo.org/686128 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/rasdaemon')
-rw-r--r--app-admin/rasdaemon/files/rasdaemon.confd2
-rw-r--r--app-admin/rasdaemon/files/rasdaemon.openrc-r221
-rw-r--r--app-admin/rasdaemon/rasdaemon-0.6.2-r4.ebuild64
3 files changed, 87 insertions, 0 deletions
diff --git a/app-admin/rasdaemon/files/rasdaemon.confd b/app-admin/rasdaemon/files/rasdaemon.confd
new file mode 100644
index 000000000000..2b89db191cd7
--- /dev/null
+++ b/app-admin/rasdaemon/files/rasdaemon.confd
@@ -0,0 +1,2 @@
+# pass the -record option if sqlite is enabled and you wish store events in sqlite
+#RASDAEMON_ARGS=-record
diff --git a/app-admin/rasdaemon/files/rasdaemon.openrc-r2 b/app-admin/rasdaemon/files/rasdaemon.openrc-r2
new file mode 100644
index 000000000000..c8a2bc4b0e65
--- /dev/null
+++ b/app-admin/rasdaemon/files/rasdaemon.openrc-r2
@@ -0,0 +1,21 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="Starts Reliablity, Availability and Serviceability (RAS) service"
+
+depend() {
+ need localmount
+ use logger
+}
+
+command="/usr/sbin/rasdaemon"
+command_args="${RASDAEMON_ARGS}"
+
+start_post() {
+ "${command}" --enable >/dev/null 2>&1
+}
+
+stop_post() {
+ "${command}" --disable >/dev/null 2>&1
+}
diff --git a/app-admin/rasdaemon/rasdaemon-0.6.2-r4.ebuild b/app-admin/rasdaemon/rasdaemon-0.6.2-r4.ebuild
new file mode 100644
index 000000000000..5659b1666afe
--- /dev/null
+++ b/app-admin/rasdaemon/rasdaemon-0.6.2-r4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+DESCRIPTION="Reliability, Availability and Serviceability logging tool"
+HOMEPAGE="http://www.infradead.org/~mchehab/rasdaemon/"
+SRC_URI="http://www.infradead.org/~mchehab/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sqlite"
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+ sys-devel/gettext
+ sys-apps/dmidecode
+ sqlite? (
+ dev-db/sqlite
+ dev-perl/DBD-SQLite
+ )
+"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ local CONFIG_CHECK="~ACPI_EXTLOG"
+ check_extra_config
+}
+
+src_configure() {
+ local myconf=(
+ --enable-abrt-report
+ --enable-aer
+ --enable-arm
+ --enable-extlog
+ --enable-hisi-ns-decode
+ --enable-mce
+ --enable-non-standard
+ --enable-sqlite3
+ --includedir="/usr/include/${PN}"
+ --localstatedir=/var
+ )
+ if use sqlite ; then
+ myconf="${myconf} --enable-sqlite3)"
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ keepdir "/var/lib/${PN}"
+
+ systemd_dounit misc/*.service
+
+ newinitd "${FILESDIR}/rasdaemon.openrc-r2" rasdaemon
+ newinitd "${FILESDIR}/ras-mc-ctl.openrc-r1" ras-mc-ctl
+ newconfd "${FILESDIR}"/rasdaemon.confd rasdaemon
+}