summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-03-01 22:54:28 +0800
committerJason Zaman <perfinion@gentoo.org>2018-03-02 14:06:14 +0800
commit6161f66ab37d1e9d97decb4ea9d3082940321a5d (patch)
tree101e8191d574cf3d4c906428f4f8515135134302 /app-admin/setools
parentsys-process/audit: Add python3_6 compat (diff)
downloadgentoo-6161f66ab37d1e9d97decb4ea9d3082940321a5d.tar.gz
gentoo-6161f66ab37d1e9d97decb4ea9d3082940321a5d.tar.bz2
gentoo-6161f66ab37d1e9d97decb4ea9d3082940321a5d.zip
app-admin/setools: add python3_6 compat
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-admin/setools')
-rw-r--r--app-admin/setools/setools-4.1.1.ebuild4
-rw-r--r--app-admin/setools/setools-9999.ebuild7
2 files changed, 6 insertions, 5 deletions
diff --git a/app-admin/setools/setools-4.1.1.ebuild b/app-admin/setools/setools-4.1.1.ebuild
index 28df40b3ee55..f9967bce90f1 100644
--- a/app-admin/setools/setools-4.1.1.ebuild
+++ b/app-admin/setools/setools-4.1.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
inherit distutils-r1
diff --git a/app-admin/setools/setools-9999.ebuild b/app-admin/setools/setools-9999.ebuild
index f1e79d0d9367..bc6d48e45d58 100644
--- a/app-admin/setools/setools-9999.ebuild
+++ b/app-admin/setools/setools-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
inherit distutils-r1
@@ -39,12 +39,13 @@ DEPEND="${RDEPEND}
test? (
python_targets_python2_7? ( dev-python/mock[${PYTHON_USEDEP}] )
dev-python/tox[${PYTHON_USEDEP}]
+ sys-apps/checkpolicy
)"
python_prepare_all() {
sed -i "s/'-Werror', //" "${S}"/setup.py || die "failed to remove Werror"
- use X || local PATCHES=( "${FILESDIR}"/setools-4.1.0-remove-gui.patch )
+ use X || local PATCHES=( "${FILESDIR}"/setools-4.1.1-remove-gui.patch )
distutils-r1_python_prepare_all
}