summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/socklog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/socklog')
-rw-r--r--app-admin/socklog/Manifest1
-rw-r--r--app-admin/socklog/files/socklog-2.1.0-headers.patch54
-rw-r--r--app-admin/socklog/metadata.xml5
-rw-r--r--app-admin/socklog/socklog-2.1.0.ebuild37
4 files changed, 97 insertions, 0 deletions
diff --git a/app-admin/socklog/Manifest b/app-admin/socklog/Manifest
new file mode 100644
index 000000000000..418666729fee
--- /dev/null
+++ b/app-admin/socklog/Manifest
@@ -0,0 +1 @@
+DIST socklog-2.1.0.tar.gz 56942 SHA256 aa869a787ee004da4e5509b5a0031bcc17a4ab4ac650c2ce8d4e488123acb455 SHA512 920ce5e661a6a3d970fa77ee3c228d48699ea03530be2b43b7517458b25e31a0a7f352ece2d076c715b6d34dbb26b424b48eb0f55b9bcd0355b74d3e34c77ac7 WHIRLPOOL b0dcf0eeacbd3edb0465ccbd40ec546fe293c3d293fac254e11ca8c07514b01de2a6d45a6ef0ce697e33a5d631810af62955fb66333f2606f36dc51587025806
diff --git a/app-admin/socklog/files/socklog-2.1.0-headers.patch b/app-admin/socklog/files/socklog-2.1.0-headers.patch
new file mode 100644
index 000000000000..b7c10e3da606
--- /dev/null
+++ b/app-admin/socklog/files/socklog-2.1.0-headers.patch
@@ -0,0 +1,54 @@
+add missing headers for misc funcs and types
+
+--- a/chkshsgr.c
++++ b/chkshsgr.c
+@@ -1,10 +1,11 @@
+ /* Public domain. */
+
+ #include <unistd.h>
++#include <grp.h>
+
+ int main()
+ {
+- short x[4];
++ gid_t x[4];
+
+ x[0] = x[1] = 0;
+ if (getgroups(1,x) == 0) if (setgroups(1,x) == -1) _exit(1);
+--- a/pathexec_run.c
++++ b/pathexec_run.c
+@@ -1,5 +1,6 @@
+ /* Public domain. */
+
++#include <unistd.h>
+ #include "error.h"
+ #include "stralloc.h"
+ #include "str.h"
+--- a/prot.c
++++ b/prot.c
+@@ -1,12 +1,15 @@
+ /* Public domain. */
+
++#include <unistd.h>
++#include <grp.h>
++
+ #include "hasshsgr.h"
+ #include "prot.h"
+
+ int prot_gid(int gid)
+ {
+ #ifdef HASSHORTSETGROUPS
+- short x[2];
++ gid_t x[2];
+ x[0] = gid; x[1] = 73; /* catch errors */
+ if (setgroups(1,x) == -1) return -1;
+ #else
+--- a/seek_set.c
++++ b/seek_set.c
+@@ -1,5 +1,6 @@
+ /* Public domain. */
+
++#include <unistd.h>
+ #include <sys/types.h>
+ #include "seek.h"
+
diff --git a/app-admin/socklog/metadata.xml b/app-admin/socklog/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/app-admin/socklog/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>
diff --git a/app-admin/socklog/socklog-2.1.0.ebuild b/app-admin/socklog/socklog-2.1.0.ebuild
new file mode 100644
index 000000000000..2a024b297795
--- /dev/null
+++ b/app-admin/socklog/socklog-2.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="small secure replacement for syslogd with automatic log rotation"
+HOMEPAGE="http://smarden.org/socklog/"
+SRC_URI="http://smarden.org/socklog/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static"
+
+RDEPEND=">=sys-process/runit-1.4.0"
+
+S=${WORKDIR}/admin/${P}/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1.0-headers.patch
+ use static && append-ldflags -static
+ echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS}" > conf-ld
+}
+
+src_install() {
+ dobin tryto uncat socklog-check || die
+ dosbin socklog socklog-conf || die
+
+ cd ..
+ dodoc package/CHANGES
+ dohtml doc/*.html
+ doman man/*
+}