summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2016-09-15 14:08:36 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-09-22 00:23:40 +0200
commit12d5f4db3e722c284b843f7222b20d5dd6564b26 (patch)
treea985ebbbf16ba39b6fd184ec75e3c56375d23bfa /app-admin/stow
parentwww-apps/chromedriver-bin: initial ebuild (diff)
downloadgentoo-12d5f4db3e722c284b843f7222b20d5dd6564b26.tar.gz
gentoo-12d5f4db3e722c284b843f7222b20d5dd6564b26.tar.bz2
gentoo-12d5f4db3e722c284b843f7222b20d5dd6564b26.zip
app-admin/stow: cleanup and keyword for arm.
* remove 99stow file. * clean up src_install. * EAPI 6 bump. * keyword for the arm platform. Closes: https://github.com/gentoo/gentoo/pull/2333 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-admin/stow')
-rw-r--r--app-admin/stow/files/99stow3
-rw-r--r--app-admin/stow/stow-2.2.2.ebuild27
2 files changed, 3 insertions, 27 deletions
diff --git a/app-admin/stow/files/99stow b/app-admin/stow/files/99stow
deleted file mode 100644
index 07625f392537..000000000000
--- a/app-admin/stow/files/99stow
+++ /dev/null
@@ -1,3 +0,0 @@
-LDPATH=/var/lib/lib
-PATH=/var/lib/bin
-MANPATH=/var/lib/share/man
diff --git a/app-admin/stow/stow-2.2.2.ebuild b/app-admin/stow/stow-2.2.2.ebuild
index 14c9b9389755..425c180c88ff 100644
--- a/app-admin/stow/stow-2.2.2.ebuild
+++ b/app-admin/stow/stow-2.2.2.ebuild
@@ -2,17 +2,15 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
-inherit eutils
-
-DESCRIPTION="Manage installation of software in /var/lib/"
+DESCRIPTION="GNU Stow is a symlink farm manager"
HOMEPAGE="https://www.gnu.org/software/stow/"
SRC_URI="mirror://gnu/stow/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="test"
DEPEND="dev-lang/perl
@@ -21,22 +19,3 @@ DEPEND="dev-lang/perl
dev-perl/Test-Output
)"
RDEPEND="dev-lang/perl"
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
-
- # create new STOWDIR
- dodir /var/lib/stow
-
- # install env.d file to add STOWDIR to PATH and LDPATH
- doenvd "${FILESDIR}"/99stow || die "doenvd failed"
-}
-
-pkg_postinst() {
- elog "We now recommend that you use /var/lib/stow as your STOWDIR"
- elog "instead of /usr/local in order to avoid conflicts with the"
- elog "symlink from /usr/lib64 -> /usr/lib. See Bug 246264 for"
- elog "more details on this change."
- elog "For your convenience, PATH has been updated to include"
- elog "/var/lib/stow/bin."
-}