summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-09-08 11:23:36 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-09-08 12:08:37 +0200
commit51ccff6cbbd11d9958e60cbecb70e4d29db4b59d (patch)
tree0f656a5074db3bea24d771ecaf2e9beb7049ce22 /app-admin/sudo
parentdev-db/oracle-instantclient: version bump to 12.2.0.1 (diff)
downloadgentoo-51ccff6cbbd11d9958e60cbecb70e4d29db4b59d.tar.gz
gentoo-51ccff6cbbd11d9958e60cbecb70e4d29db4b59d.tar.bz2
gentoo-51ccff6cbbd11d9958e60cbecb70e4d29db4b59d.zip
app-admin/sudo: Bump to version 1.8.21_p2
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-admin/sudo')
-rw-r--r--app-admin/sudo/Manifest1
-rw-r--r--app-admin/sudo/sudo-1.8.21_p2.ebuild218
2 files changed, 219 insertions, 0 deletions
diff --git a/app-admin/sudo/Manifest b/app-admin/sudo/Manifest
index cc3eccf89e80..4b679893996b 100644
--- a/app-admin/sudo/Manifest
+++ b/app-admin/sudo/Manifest
@@ -1,3 +1,4 @@
DIST sudo-1.8.20p2.tar.gz 2930769 SHA256 bd42ae1059e935f795c69ea97b3de09fe9410a58a74b5d5e6836eb5067a445d9 SHA512 8bf67e687f7a84605fdef8d547b5cd661141b6c8fd25820c33c7e37e97ca7f21f564c3bae691f8a8cd08df7d80338e36a8f06bb5086cc104509d71d6ab1bceda WHIRLPOOL 4e9b6ddaba8cdb4d82358e01252136af56ae50f656f9802285471c7c1e5c831d26aa07cb78205f63ea6098f98846911938681a89256afe5419372039d0e4e792
DIST sudo-1.8.21.tar.gz 2973939 SHA256 126e9214613e842e19a02658f060186fe6a5927948679d64895b17ed933bb523 SHA512 f3e4a39b6d5a58bc94e1d8ce997460fc317abd7ff8dce75c23a37668cba96ff3edbac76580b4d8bfec585013c6ff30b004d9eda6fe775700abe54ba9eaa9f31f WHIRLPOOL 7add1abf9badc68ec7ef10d99cd6c57cd6d279a66e342ad544f511e7f0c8d59bc1ddbf7d5d7cc91b72fe71d23d3f3005e5b60df1d0f6e2bf08c2b12745d093c2
DIST sudo-1.8.21p1.tar.gz 2975522 SHA256 ee50d3a249a96b1c5c8d3d21380eb96c63c6e61a888b13e3c2b941b23ab7c808 SHA512 081dff35cbc2724b0481139490601665b7e10e19c8cffcd00918cb51a914f1b7103c7d04b3361e229b63d404c68c47598ca6f59a7c3c00a5b3b7aed74bae9e45 WHIRLPOOL 13f8dba536f7e70b8025bddbe25ca73859d062f3ffe7f3137fc4393453f59863a7984cd0de250e6c6fa4a34e2a1e2f617932e506cca4327d64ae49f8913bbe92
+DIST sudo-1.8.21p2.tar.gz 2976081 SHA256 74c5746cd33a814e2431c39faf0d76f7f8a697379bd073862e3b156cf0d76368 SHA512 f04bbff54ad74ba73c078e15c75d2f41332d4912078ed66157ba7346b7fff914bd0747460cb4cd0c472af2d3b344fa72f5c62c95169df68a9cac74d7245c720c WHIRLPOOL 94d9c9abdbb93f37f13179e934004b61f930978a4b0372aa0ccf0ff1aead51af272cb296554affb24e92d7f828b285f0d923fb87b19e1173e470f4b27fa1e538
diff --git a/app-admin/sudo/sudo-1.8.21_p2.ebuild b/app-admin/sudo/sudo-1.8.21_p2.ebuild
new file mode 100644
index 000000000000..0af84eaf37f1
--- /dev/null
+++ b/app-admin/sudo/sudo-1.8.21_p2.ebuild
@@ -0,0 +1,218 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils pam multilib libtool
+
+MY_P=${P/_/}
+MY_P=${MY_P/beta/b}
+
+uri_prefix=
+case ${P} in
+ *_beta*|*_rc*) uri_prefix=beta/ ;;
+esac
+
+DESCRIPTION="Allows users or groups to run commands as other users"
+HOMEPAGE="http://www.sudo.ws/"
+SRC_URI="http://www.sudo.ws/sudo/dist/${uri_prefix}${MY_P}.tar.gz
+ ftp://ftp.sudo.ws/pub/sudo/${uri_prefix}${MY_P}.tar.gz"
+
+# Basic license is ISC-style as-is, some files are released under
+# 3-clause BSD license
+LICENSE="ISC BSD"
+SLOT="0"
+if [[ ${PV} != *_beta* ]] && [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~sparc-solaris"
+fi
+IUSE="gcrypt ldap nls pam offensive openssl sasl selinux +sendmail skey"
+
+CDEPEND="
+ gcrypt? ( dev-libs/libgcrypt:= )
+ openssl? ( dev-libs/openssl:0= )
+ pam? ( virtual/pam )
+ sasl? ( dev-libs/cyrus-sasl )
+ skey? ( >=sys-auth/skey-1.1.5-r1 )
+ ldap? (
+ >=net-nds/openldap-2.1.30-r1
+ dev-libs/cyrus-sasl
+ )
+ sys-libs/zlib
+"
+RDEPEND="
+ ${CDEPEND}
+ selinux? ( sec-policy/selinux-sudo )
+ ldap? ( dev-lang/perl )
+ pam? ( sys-auth/pambase )
+ >=app-misc/editor-wrapper-3
+ virtual/editor
+ sendmail? ( virtual/mta )
+"
+DEPEND="
+ ${CDEPEND}
+ sys-devel/bison
+"
+
+S="${WORKDIR}/${MY_P}"
+
+REQUIRED_USE="
+ pam? ( !skey )
+ skey? ( !pam )
+ ?? ( gcrypt openssl )
+"
+
+MAKEOPTS+=" SAMPLES="
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+set_rootpath() {
+ # FIXME: secure_path is a compile time setting. using ROOTPATH
+ # is not perfect, env-update may invalidate this, but until it
+ # is available as a sudoers setting this will have to do.
+ einfo "Setting secure_path ..."
+
+ # first extract the default ROOTPATH from build env
+ ROOTPATH=$(unset ROOTPATH; . "${EPREFIX}"/etc/profile.env; echo "${ROOTPATH}")
+ if [[ -z ${ROOTPATH} ]] ; then
+ ewarn " Failed to find ROOTPATH, please report this"
+ fi
+
+ # then remove duplicate path entries
+ cleanpath() {
+ local newpath thisp IFS=:
+ for thisp in $1 ; do
+ if [[ :${newpath}: != *:${thisp}:* ]] ; then
+ newpath+=:$thisp
+ else
+ einfo " Duplicate entry ${thisp} removed..."
+ fi
+ done
+ ROOTPATH=${newpath#:}
+ }
+ cleanpath /bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/opt/bin${ROOTPATH:+:${ROOTPATH}}
+
+ # finally, strip gcc paths #136027
+ rmpath() {
+ local e newpath thisp IFS=:
+ for thisp in ${ROOTPATH} ; do
+ for e ; do [[ $thisp == $e ]] && continue 2 ; done
+ newpath+=:$thisp
+ done
+ ROOTPATH=${newpath#:}
+ }
+ rmpath '*/gcc-bin/*' '*/gnat-gcc-bin/*' '*/gnat-gcc/*'
+
+ einfo "... done"
+}
+
+src_configure() {
+ local ROOTPATH
+ set_rootpath
+
+ # audit: somebody got to explain me how I can test this before I
+ # enable it.. - Diego
+ # plugindir: autoconf code is crappy and does not delay evaluation
+ # until `make` time, so we have to use a full path here rather than
+ # basing off other values.
+ myeconfargs=(
+ --enable-zlib=system
+ --with-editor="${EPREFIX}"/usr/libexec/editor
+ --with-env-editor
+ --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/sudo
+ --with-rundir="${EPREFIX}"/var/run/sudo
+ --with-secure-path="${ROOTPATH}"
+ --with-vardir="${EPREFIX}"/var/db/sudo
+ --without-linux-audit
+ --without-opie
+ $(use_enable gcrypt)
+ $(use_enable nls)
+ $(use_enable openssl)
+ $(use_enable sasl)
+ $(use_with offensive insults)
+ $(use_with offensive all-insults)
+ $(use_with ldap ldap_conf_file /etc/ldap.conf.sudo)
+ $(use_with ldap)
+ $(use_with pam)
+ $(use_with skey)
+ $(use_with selinux)
+ $(use_with sendmail)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use ldap ; then
+ dodoc README.LDAP
+ dosbin plugins/sudoers/sudoers2ldif
+
+ cat <<-EOF > "${T}"/ldap.conf.sudo
+ # See ldap.conf(5) and README.LDAP for details
+ # This file should only be readable by root
+
+ # supported directives: host, port, ssl, ldap_version
+ # uri, binddn, bindpw, sudoers_base, sudoers_debug
+ # tls_{checkpeer,cacertfile,cacertdir,randfile,ciphers,cert,key}
+ EOF
+
+ insinto /etc
+ doins "${T}"/ldap.conf.sudo
+ fperms 0440 /etc/ldap.conf.sudo
+
+ insinto /etc/openldap/schema
+ newins doc/schema.OpenLDAP sudo.schema
+ fi
+
+ pamd_mimic system-auth sudo auth account session
+
+ keepdir /var/db/sudo
+ fperms 0700 /var/db/sudo
+
+ # Don't install into /var/run as that is a tmpfs most of the time
+ # (bug #504854)
+ rm -rf "${D}"/var/run
+}
+
+pkg_postinst() {
+ if use ldap ; then
+ ewarn
+ ewarn "sudo uses the /etc/ldap.conf.sudo file for ldap configuration."
+ ewarn
+ if grep -qs '^[[:space:]]*sudoers:' "${ROOT}"/etc/nsswitch.conf ; then
+ ewarn "In 1.7 series, LDAP is no more consulted, unless explicitly"
+ ewarn "configured in /etc/nsswitch.conf."
+ ewarn
+ ewarn "To make use of LDAP, add this line to your /etc/nsswitch.conf:"
+ ewarn " sudoers: ldap files"
+ ewarn
+ fi
+ fi
+ if use prefix ; then
+ ewarn
+ ewarn "To use sudo, you need to change file ownership and permissions"
+ ewarn "with root privileges, as follows:"
+ ewarn
+ ewarn " # chown root:root ${EPREFIX}/usr/bin/sudo"
+ ewarn " # chown root:root ${EPREFIX}/usr/lib/sudo/sudoers.so"
+ ewarn " # chown root:root ${EPREFIX}/etc/sudoers"
+ ewarn " # chown root:root ${EPREFIX}/etc/sudoers.d"
+ ewarn " # chown root:root ${EPREFIX}/var/db/sudo"
+ ewarn " # chmod 4111 ${EPREFIX}/usr/bin/sudo"
+ ewarn
+ fi
+
+ elog "To use the -A (askpass) option, you need to install a compatible"
+ elog "password program from the following list. Starred packages will"
+ elog "automatically register for the use with sudo (but will not force"
+ elog "the -A option):"
+ elog ""
+ elog " [*] net-misc/ssh-askpass-fullscreen"
+ elog " net-misc/x11-ssh-askpass"
+ elog ""
+ elog "You can override the choice by setting the SUDO_ASKPASS environmnent"
+ elog "variable to the program you want to use."
+}