summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-07-25 00:32:56 +0200
committerMichał Górny <mgorny@gentoo.org>2017-07-26 17:31:46 +0200
commit44d807845ea5ad104cf75b38de80066d9a587838 (patch)
treea9985d62548be02a6f26e2ee16036e48d7f15201 /app-admin/supervisor
parentapp-admin/supervisor: bump to 3.1.4 (diff)
downloadgentoo-44d807845ea5ad104cf75b38de80066d9a587838.tar.gz
gentoo-44d807845ea5ad104cf75b38de80066d9a587838.tar.bz2
gentoo-44d807845ea5ad104cf75b38de80066d9a587838.zip
app-admin/supervisor: bump to 3.3.3
Bug: https://bugs.gentoo.org/show_bug.cgi?id=626100 Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'app-admin/supervisor')
-rw-r--r--app-admin/supervisor/Manifest1
-rw-r--r--app-admin/supervisor/supervisor-3.3.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-admin/supervisor/Manifest b/app-admin/supervisor/Manifest
index 6e5f5aa1877f..b24583a66482 100644
--- a/app-admin/supervisor/Manifest
+++ b/app-admin/supervisor/Manifest
@@ -2,3 +2,4 @@ DIST supervisor-3.1.3.tar.gz 391529 SHA256 e32c546fe8d2a6e079ec4819c49fd24534d40
DIST supervisor-3.1.4.tar.gz 392321 SHA256 82f75089f719a7a3ca87f35c89a03c20fd3c0912552c96eb6fa40274ced6604e SHA512 7182db4169d37aa8f7a2a4e1d57ce40f6dea21759ed73fb49286dd5ffb2bdede0fccdc71344e93c8f8c067a2cbc4e3cb0a9a50b22bacdb1b8bc1378581ed5f07 WHIRLPOOL 64a3b7c46b6c2a2c5d67ebfc44fef0f3382ff98a2468b3c210f03b205a3cbf6d7604788b985c98b093c20a1950b4a343a86cf914713072fa2f28f50f0478f63e
DIST supervisor-3.3.1.tar.gz 415246 SHA256 fc3af22e5a7af2f6c3be787acf055c1c17777f5607cd4dc935fe633ab97061fd SHA512 e67d4e7b01f6f98a595e7524c5318e780b422a7f8f932f205c6a4d74c3c9e058b265b1732e944e5b467daa6ceffde7d1aae1f1af12c2b7c53728739edb10f740 WHIRLPOOL 744fd11df897ac25839138ce12bf194682b4d0576396b692ef2befecdffb658ed9c2a47aa2248793b082c674cb9a3dc39c0c38127e4a2da74028fb8606500336
DIST supervisor-3.3.2.tar.gz 417348 SHA256 bbb870f5b59c5c4fd79f711553e343158b2c64688997a23a1bcb2ce643f57771 SHA512 959f045d8da5a263a6990fdc4a93154684c74cca5f49aeb733b86da046a8a3a56981062d16f0ab8177c0e0bb41f137c62e1ae6a52582e76bbe0adb2b8185202c WHIRLPOOL 2cd1bae59d187d9623089a4c9bcc11773a7fd371fc8725b34b28cd5b342391ddf92dd1c3d77f7eed53ab0209fd611fd3ce0e9b15e108b422189620d97cb37658
+DIST supervisor-3.3.3.tar.gz 418354 SHA256 96287ebfabf9a6923f74123b056c4da39c617fef367980f007cac02fba6527ad SHA512 8285445da8a0ed790fbdf75d988304ab8fcefd9c36975ae6526ec58f511c73cd8707f22b7cff40c3aed5e63f3665d096ed4b5dbc2cc456fe0c5b4547149dbb4a WHIRLPOOL e7d880f76fb6a3eabe6d4c78c19464e1f4880d195e58bdd10d829beb8962f9d8bd39ac5274ec96c6d47ac9478f5f3b80a36131cbbda275bc23b33bd664ca9d2a
diff --git a/app-admin/supervisor/supervisor-3.3.3.ebuild b/app-admin/supervisor/supervisor-3.3.3.ebuild
new file mode 100644
index 000000000000..7297e311db18
--- /dev/null
+++ b/app-admin/supervisor/supervisor-3.3.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 ) # py2 only
+# xml.etree.ElementTree module required.
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+MY_PV="${PV/_beta/b}"
+
+DESCRIPTION="A system for controlling process state under UNIX"
+HOMEPAGE="http://supervisord.org/ https://pypi.python.org/pypi/supervisor"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="repoze ZPL BSD HPND GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/meld3[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ newinitd "${FILESDIR}/init.d-r1" supervisord
+ newconfd "${FILESDIR}/conf.d" supervisord
+ use doc && local HTML_DOCS=( docs/.build/html/. )
+ distutils-r1_python_install_all
+}