summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Beddek <telans@posteo.de>2021-10-24 10:42:08 +1300
committerSam James <sam@gentoo.org>2021-10-24 04:17:32 +0000
commit7af006160b8e828a7fe0695a212275b6bedb0ca4 (patch)
tree9ace44558a830dbd86ca75cf6ef83fb2b82c3f78 /app-admin/usbview
parentapp-admin/usbview: add myself as a maintainer (diff)
downloadgentoo-7af006160b8e828a7fe0695a212275b6bedb0ca4.tar.gz
gentoo-7af006160b8e828a7fe0695a212275b6bedb0ca4.tar.bz2
gentoo-7af006160b8e828a7fe0695a212275b6bedb0ca4.zip
app-admin/usbview: add 2.1
Signed-off-by: James Beddek <telans@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/22687 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin/usbview')
-rw-r--r--app-admin/usbview/Manifest1
-rw-r--r--app-admin/usbview/usbview-2.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/usbview/Manifest b/app-admin/usbview/Manifest
index 7c6df7c5b4ce..96a8cfafcba0 100644
--- a/app-admin/usbview/Manifest
+++ b/app-admin/usbview/Manifest
@@ -1 +1,2 @@
DIST usbview-2.0.tar.gz 366337 BLAKE2B d3ce8f3b97ebb650f7cc8b47d7a4c4b985022811f55b43b41a65aaa120450aa187ce2dfc2671315575dfcbd108b68ca50420145a6c59ab85f7c4fcfc53a233f9 SHA512 87b3d0b0c734c94e5527f19575c0460f5c0b894dac29936a759d573058c9c007ad59c9be32a5c6d485cba258193efe4ca15bdd6f3ca31df321ed230778b5404f
+DIST usbview-2.1.tar.gz 377376 BLAKE2B 76e6a45a31006f7a7b69783b608dd33304a1a3401c784bfdce62079c764795cbd4914b030ca44884f2f9dd14a479bd679be6c1eabd8bc1776a902b4d1446d82f SHA512 7d973eb9ad74e8c0842396e6239ee44d5feab2d3ce412f7c91e18b947604bcf3c2d3dc456bbefc4cd7567a03d9306593b378ce29c3fb3b13eefe75af3f4c14d4
diff --git a/app-admin/usbview/usbview-2.1.ebuild b/app-admin/usbview/usbview-2.1.ebuild
new file mode 100644
index 000000000000..e5d607ada575
--- /dev/null
+++ b/app-admin/usbview/usbview-2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info
+
+DESCRIPTION="Display the topology of devices on the USB bus"
+HOMEPAGE="http://www.kroah.com/linux-usb/ https://github.com/gregkh/usbview"
+SRC_URI="http://www.kroah.com/linux-usb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/imagemagick-tools[png,svg]
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ CONFIG_CHECK="~DEBUG_FS"
+ linux-info_pkg_setup
+}