summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-02-20 19:43:07 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-02-20 19:43:07 -0600
commit0e36833911f5489019cec9a64ff8be533344bb88 (patch)
treec2b78afe306deae3d4681dc317ab9166f22a5688 /app-admin
parentapp-admin/ansible: 2.9.4 stable amd64/x86 (diff)
downloadgentoo-0e36833911f5489019cec9a64ff8be533344bb88.tar.gz
gentoo-0e36833911f5489019cec9a64ff8be533344bb88.tar.bz2
gentoo-0e36833911f5489019cec9a64ff8be533344bb88.zip
app-admin/ansible: cleanup
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-2.9.3.ebuild68
2 files changed, 0 insertions, 69 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 6d9a72a3ee8d..435d46816729 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,3 +1,2 @@
-DIST ansible-2.9.3.tar.gz 14170666 BLAKE2B bb27d249e2390888ee3c28fdb48c1ceff346d2903089c70b451f793742238498aed7c33be056cce9790f44f5cdb74b5020b6decf4f1242904bd9c8f7b5077ea0 SHA512 02cfa2c7c43506dc602e92aed66c920243222b82bc4852f1a4d786cd3ff26fe17eda18d35ac7301cd9bf26366df9b18776e2a27e8d54fc92c3128f52ec7f58e8
DIST ansible-2.9.4.tar.gz 14170264 BLAKE2B e230837360d29df460906d118b3c2ebb9a9dc1ac2a4427809a16716e67a79db8e737ed1beca757bd8a75b631c8cb6c26e58b1caeaaeb613731d63031f1e4e34e SHA512 21020548100fc31b59d4ee1b461f2a14359f2f18752d431cd041eb987c8c8b308f1aa1687461a9b3f5a086485b77b3a38c8f006b942cc24cb2157b45e6582822
DIST ansible-2.9.5.tar.gz 14186885 BLAKE2B c64fb384ab55c5b9cca753319fba911b8a40d634b59998f2e4c65ccafaa536788f3ac8c18a45a4b0d322ecca9b7fa2c580311a35a202ad70c2de2157ab04bfaf SHA512 cd2ce807b3136e2c02856339ea910b0a5cae8ca946da804ed7d3ec5725d3eff0fe5b4bd8527b2a17d6f3109e16859d52045b50f2ffd21169b30768e65b813407
diff --git a/app-admin/ansible/ansible-2.9.3.ebuild b/app-admin/ansible/ansible-2.9.3.ebuild
deleted file mode 100644
index 4e4f9dd72e82..000000000000
--- a/app-admin/ansible/ansible-2.9.3.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://ansible.com/"
-SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~x64-macos"
-IUSE="doc test"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile_all() {
- if use doc; then
- cd docs/docsite || die
- export CPUS=4
- emake -f Makefile.sphinx html
- fi
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
- distutils-r1_python_install_all
-
- dodoc -r examples
-}