summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-11 09:57:36 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-11 09:58:02 -0600
commit0ffed3e29652571da350d48f08b26a3e81917630 (patch)
treee4db72ae96b19557965546eda7d7b1a3d980661a /app-admin
parentwww-client/epiphany: Drop old (diff)
downloadgentoo-0ffed3e29652571da350d48f08b26a3e81917630.tar.gz
gentoo-0ffed3e29652571da350d48f08b26a3e81917630.tar.bz2
gentoo-0ffed3e29652571da350d48f08b26a3e81917630.zip
app-admin/puppet-agent: 1.9.1 bup
Package-Manager: portage-2.3.3
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.9.1.ebuild106
2 files changed, 108 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index ca74d70e478e..7bd2eb409430 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -6,3 +6,5 @@ DIST puppet-agent_1.8.3-1xenial_amd64.deb 15531434 SHA256 2a468846e4b31f07dce9bb
DIST puppet-agent_1.8.3-1xenial_i386.deb 16564720 SHA256 c2d5a1fd91941031b375b59f85f323a38977cc526b33e73f93eae50ee036fd65 SHA512 bb617c351ba26d431a6f0d6aa150c8888ee822feb63ebb56557586547e8afc9d387c5af6a6c59e6a885bc6ab195c89b3ea9317de74440abe6df76870c3dca345 WHIRLPOOL cdfd414d9113add49f9b60d5efcd5f16ce0f71a1bb094a4e98c31486b8ff86b1f9dbe1b5da0724358aa78d8f75c3aed9c8247a62595cdde92eab74519b9d06ef
DIST puppet-agent_1.9.0-1xenial_amd64.deb 15324700 SHA256 acdcdc314b39e404102b8e6d0a7d1fdeb5710efeb34f60c447afd95a17a230c4 SHA512 068e27aa59b7e60eb296a7d41435ae821559822f4e4136dae0af20445490a209baabfd0bbe5f91c8981091c999170c251310c5a6fdc0ffd9825f1d0ee7128e06 WHIRLPOOL b949befa1ad7f61877188828a90687f2a5957831af8a71723ab7424172d5df04b923f5241681a816f28382e3ac832fab2c7982c34f1f12db6f31ca9440f0ec2d
DIST puppet-agent_1.9.0-1xenial_i386.deb 16775966 SHA256 c7c5303e411278d19eee798ab7ae68b51edc7256935e6637a58fbb8c035df6ed SHA512 00a29cf00840e8d75e5d858fe03a15338f21e9eead123a1bae5e2a8cca66e06a6bbdc4671a06a986ee8807851997459fc134c6ebb196674e6993fd12af5bbd47 WHIRLPOOL ebac057af1efeb692b6b56fe2a697a79ab45872639add7db903b24f176651e86dfc18651c25acef3b33682dda255562e357e0942b9121b232474dcf1f6617176
+DIST puppet-agent_1.9.1-1xenial_amd64.deb 15458462 SHA256 ed7a124842b48a3ec16875dfbdf8942437d1d137768003918ef681838f2bcfc6 SHA512 1eaba0dabc7000b873dc776f74f7f0ea2084cdb0ffb39f4d344798458e20b36f233256d4648676954ecaad7dd1f0762823febe4e948c622dd8e1a599cb23cb7c WHIRLPOOL d1ba1ebc8519eb7329203d9fffd8447c7d3a141cfad798c09dc7011442f7a38da41b9b275778e6c5d5929fae94bd89ee9033f847bb1116d3afe7be90bd4525e0
+DIST puppet-agent_1.9.1-1xenial_i386.deb 16870810 SHA256 6739a03ab3ffa69680c84aed79f50e3e0383a50055b1e5f5545a24aec68c3791 SHA512 421b32d2eba33af0bbbbbd41f3615222c1907107023f6cb80bb23a9378f5ba9cc26bac24749c611cc41fc52bca25df92377ba76cfd2d09d1328067138d2a8db3 WHIRLPOOL e9abd1b50856577e7892511b94f9ca64b023f41ff39c6fd106874305380522cf7fd98e0d659eb896d400fd8865510dec7144a7915fa4f3bb069069d74302612f
diff --git a/app-admin/puppet-agent/puppet-agent-1.9.1.ebuild b/app-admin/puppet-agent/puppet-agent-1.9.1.ebuild
new file mode 100644
index 000000000000..da0a3ddaee79
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.9.1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/xenial/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1xenial"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/glibc
+ >=sys-libs/readline-6.0
+ <sys-libs/readline-7.0
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.1.0 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="
+ /opt/puppetlabs/puppet
+ /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/mathn/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/io/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/dl/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/racc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/enc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/json/ext/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/rbconfig/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/digest/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/engines/*
+ /opt/puppetlabs/puppet/lib/virt-what/*
+ /opt/puppetlabs/puppet/lib/*
+ /opt/puppetlabs/puppet/bin/*"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/mcollective.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}