summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-06-25 14:36:41 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-06-25 14:37:00 +0000
commit11574dfca40a80dea200780dbbd4c35564422da6 (patch)
treef934aaa8d50e4e15bfa5157ae502b590e0add10b /app-admin
parentapp-benchmarks/contest: Minor changes. (diff)
downloadgentoo-11574dfca40a80dea200780dbbd4c35564422da6.tar.gz
gentoo-11574dfca40a80dea200780dbbd4c35564422da6.tar.bz2
gentoo-11574dfca40a80dea200780dbbd4c35564422da6.zip
app-admin/verynice: EAPI 6 bump.
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1702
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/verynice/verynice-1.1-r3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-admin/verynice/verynice-1.1-r3.ebuild b/app-admin/verynice/verynice-1.1-r3.ebuild
new file mode 100644
index 000000000000..6a1b122e582c
--- /dev/null
+++ b/app-admin/verynice/verynice-1.1-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="A tool for dynamically adjusting the nice-level of processes"
+HOMEPAGE="https://web.archive.org/web/20130621090315/ http://thermal.cnde.iastate.edu/~sdh4/verynice/"
+SRC_URI="http://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ default
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake RPM_BUILD_ROOT="${D}" PREFIX=/usr
+}
+
+src_install(){
+ emake RPM_BUILD_ROOT="${D}" PREFIX=/usr VERSION=${PVR} install
+ doinitd "${FILESDIR}"/verynice
+ systemd_dounit "${FILESDIR}"/verynice.service
+}