summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-11 07:04:27 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-11 08:34:48 +0200
commit1392eb4dc9e842f15c76d87584c4c2cfed862079 (patch)
treea9fd8ea654480dc2dca539011370f609255b3b40 /app-admin
parentdev-python/boto3: Bump to 1.24.7 (diff)
downloadgentoo-1392eb4dc9e842f15c76d87584c4c2cfed862079.tar.gz
gentoo-1392eb4dc9e842f15c76d87584c4c2cfed862079.tar.bz2
gentoo-1392eb4dc9e842f15c76d87584c4c2cfed862079.zip
app-admin/awscli: Bump to 1.25.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.7.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 04c7e616bab4..f0d002f62cfa 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.25.3.gh.tar.gz 2221419 BLAKE2B ecc3e16985426b9b6cf6a6fc5cd3cf58d0
DIST aws-cli-1.25.4.gh.tar.gz 2222045 BLAKE2B 3d8496b997e80b9504c8810a256d6886a7dee239ed0eba74d42d23955d1596d5b7690a20ac31b8f57e004ff27889e8e204b335996d2f629e9ed11b3bfd033641 SHA512 e053529c9e5429e5782e6c3afe26c212599825c78691d8c58a4c5dcd373385c1111afb2f75e09b5c1831d30ce6c890db0e4888fa4d9d874a5fc68994a8c3c5fd
DIST aws-cli-1.25.5.gh.tar.gz 2222976 BLAKE2B a726ed1ca6eb8172972c53c1418e342fa8b1f1920a3a023f63cef9a0c96e2a6e882246b8bc3caa3ff39fe0e55d66ce6993d395b7817dd1b666251f9c54d44b45 SHA512 e621237d198d15d6be662e22e7e07103969822d6324e8f63737db35c4e7b75c51d12409e1732b5a948ff2c468b7ab904f1f53903a578f04e750e426558979d68
DIST aws-cli-1.25.6.gh.tar.gz 2223055 BLAKE2B e6e16b3b67110ed185bb94e2d56cef9445b32373e92136bde53f63bb94ff7b1e8749f33b022203ba113fde676aa086ab96b409dde7e4c48cbe5512cd9f3bd65e SHA512 c0f7b27583ce774a34467f6af0796ec4c7252d9babfda6e7a484252d2de417686194b1e7b4dffc6d8545b2126f1b55288703473153f3339656e9e7a350d143d0
+DIST aws-cli-1.25.7.gh.tar.gz 2223153 BLAKE2B fcadda94fd721135f94b1538c4b27e41108064f6fd32f324d5436138e3d1b0ffcab53fcc545b01c461365d55c4bfa2a05d90e94c875c929a3227efae76452415 SHA512 194adacab0df87d8e4f0cdc71bb956bef6dc8b2de2e7e4416c9c079ff2b7c2bce7584ac1049428d0bcb134368b39c37c04bc5e6a8fc7540c44c64f3934ccaf21
diff --git a/app-admin/awscli/awscli-1.25.7.ebuild b/app-admin/awscli/awscli-1.25.7.ebuild
new file mode 100644
index 000000000000..4154af977ee6
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}