summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-02 06:23:33 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-02 06:23:33 +0200
commit2bbd9b86c24edbe1282c40fc5472db9948148bb6 (patch)
treeba2b990af2c41c44d1909d0637230e16e715cb39 /app-admin
parentdev-python/boto3: Bump to 1.34.75 (diff)
downloadgentoo-2bbd9b86c24edbe1282c40fc5472db9948148bb6.tar.gz
gentoo-2bbd9b86c24edbe1282c40fc5472db9948148bb6.tar.bz2
gentoo-2bbd9b86c24edbe1282c40fc5472db9948148bb6.zip
app-admin/awscli: Bump to 1.32.75
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.32.75.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 81867ef87358..ae674316ab3a 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,3 +1,4 @@
DIST aws-cli-1.32.64.gh.tar.gz 2672156 BLAKE2B 6707984b03e004ed8672b35694c9e4be7d2543c040a64778c0ad43a4e011f07506eb5e3f9791a5b0e23bc5bd222b625daa078f9e42cfbf6d71b7887d675c1a5a SHA512 f39472bb1ad75cbfc4bf775aee9a003a884d7423e10d9ff96f90ebe7dbd97c0db4bbd4d52f1d918372ec880d1dea8f5cf82db31118a7c29973d42149064fd8a3
DIST aws-cli-1.32.69.gh.tar.gz 2675479 BLAKE2B 7a8ec84c029662145aaf49afd1b9194a7a021249ee7bff2f5c5b704703e54ee6f09c94cd0ccf85a968187f3e8e6c85a18fa31592f6bc82dc5c2aac9aaa02a643 SHA512 09f5929fcec0ec263f80b377ee21d256c52547f9f71b8a38382b0a9d39371646d0afcc3650079147f0dc8f6fa11d33cb4a9f3977c023be37851fca761ef6ac56
DIST aws-cli-1.32.74.gh.tar.gz 2682208 BLAKE2B aba8be6e597a6d07197bd06d51f167f7a2dbed317c630572585cd006f6edfceac054726a20afe20faf6de381cbb75e352a7d6ab9e232b6e669fd59ca5888e122 SHA512 2f19b7c383c91528f15b93b00df285bdf32685c08e41e4f8f3a62cbbd5cff2615ca98c5eb925a5a2a2d13b452a0a08658749f4f7a48045a537ee7ec7e23cd663
+DIST aws-cli-1.32.75.gh.tar.gz 2683704 BLAKE2B 8dd4b7522c7684dd405018067a266842243679dac88a27de7be8b279c9a2b19081b2c49425392585a3c4a3173ff24227dc16070331ee772501db37251f12c355 SHA512 64525fe4a31074ec05531066451ab6faf8c8027fb9ad26d31d7877de1e63797c46f723cd03d89a11ba27af9dd77adec91a926e3ce32ef6e2acf0e29a45cf7908
diff --git a/app-admin/awscli/awscli-1.32.75.ebuild b/app-admin/awscli/awscli-1.32.75.ebuild
new file mode 100644
index 000000000000..4a677affdbc4
--- /dev/null
+++ b/app-admin/awscli/awscli-1.32.75.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}