summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-04-11 14:47:49 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-04-11 14:48:01 +0200
commit3c9da0087fa88a9507cdea96fcca8688461279bb (patch)
tree1eec48cd002c8f712250f7012f8c79c69efdd487 /app-admin
parentapp-admin/sudo: Bump to version 1.9.0_rc2 (diff)
downloadgentoo-3c9da0087fa88a9507cdea96fcca8688461279bb.tar.gz
gentoo-3c9da0087fa88a9507cdea96fcca8688461279bb.tar.bz2
gentoo-3c9da0087fa88a9507cdea96fcca8688461279bb.zip
app-admin/sudo: Synced live ebuild
Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sudo/sudo-9999.ebuild38
1 files changed, 17 insertions, 21 deletions
diff --git a/app-admin/sudo/sudo-9999.ebuild b/app-admin/sudo/sudo-9999.ebuild
index f0df8a6c9e22..cecc68448ea9 100644
--- a/app-admin/sudo/sudo-9999.ebuild
+++ b/app-admin/sudo/sudo-9999.ebuild
@@ -30,10 +30,11 @@ fi
# 3-clause BSD license
LICENSE="ISC BSD"
SLOT="0"
-IUSE="gcrypt ldap libressl nls offensive pam sasl +secure-path selinux +sendmail skey sssd system-digest"
+IUSE="gcrypt ldap libressl nls offensive pam sasl +secure-path selinux +sendmail skey ssl sssd"
DEPEND="
sys-libs/zlib:=
+ gcrypt? ( dev-libs/libgcrypt:= )
ldap? (
>=net-nds/openldap-2.1.30-r1
sasl? (
@@ -44,14 +45,11 @@ DEPEND="
pam? ( sys-libs/pam )
sasl? ( dev-libs/cyrus-sasl )
skey? ( >=sys-auth/skey-1.1.5-r1 )
- sssd? ( sys-auth/sssd[sudo] )
- system-digest? (
- gcrypt? ( dev-libs/libgcrypt:= )
- !gcrypt? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
)
+ sssd? ( sys-auth/sssd[sudo] )
"
RDEPEND="
${DEPEND}
@@ -137,36 +135,34 @@ src_configure() {
# until `make` time, so we have to use a full path here rather than
# basing off other values.
myeconfargs=(
- --enable-zlib=system
+ # requires some python eclass
+ --disable-python
--enable-tmpfiles.d="${EPREFIX}"/usr/lib/tmpfiles.d
+ --enable-zlib=system
--with-editor="${EPREFIX}"/usr/libexec/editor
--with-env-editor
--with-plugindir="${EPREFIX}"/usr/$(get_libdir)/sudo
--with-rundir="${EPREFIX}"/run/sudo
- $(use_with secure-path secure-path "${SECURE_PATH}")
--with-vardir="${EPREFIX}"/var/db/sudo
--without-linux-audit
--without-opie
$(use_enable gcrypt)
$(use_enable nls)
$(use_enable sasl)
+ $(use_enable ssl openssl)
+ $(use_with ldap)
+ $(use_with ldap ldap_conf_file /etc/ldap.conf.sudo)
$(use_with offensive insults)
$(use_with offensive all-insults)
- $(use_with ldap ldap_conf_file /etc/ldap.conf.sudo)
- $(use_with ldap)
$(use_with pam)
- $(use_with skey)
- $(use_with sssd)
+ $(use_with pam pam-login)
+ $(use_with secure-path secure-path "${SECURE_PATH}")
$(use_with selinux)
$(use_with sendmail)
+ $(use_with skey)
+ $(use_with sssd)
)
- if use system-digest && ! use gcrypt; then
- myeconfargs+=("--enable-openssl")
- else
- myeconfargs+=("--disable-openssl")
- fi
-
econf "${myeconfargs[@]}"
}
@@ -209,7 +205,7 @@ src_install() {
# Don't install into /run as that is a tmpfs most of the time
# (bug #504854)
- rm -rf "${ED}"/run
+ rm -rf "${ED}"/run || die
find "${ED}" -type f -name "*.la" -delete || die #697812
}