summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-02-25 17:50:33 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-02-25 17:55:15 +1100
commit551baad72ab8eee610d3093075de8cc1d379406b (patch)
treee3384ae2a5c38f8604be3cdee37e4e64600a0f61 /app-admin
parentapp-admin/keepass: stabilise 2.38 for amd64/x86 (diff)
downloadgentoo-551baad72ab8eee610d3093075de8cc1d379406b.tar.gz
gentoo-551baad72ab8eee610d3093075de8cc1d379406b.tar.bz2
gentoo-551baad72ab8eee610d3093075de8cc1d379406b.zip
app-admin/keepass: remove 2.37
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/keepass/Manifest1
-rw-r--r--app-admin/keepass/keepass-2.37.ebuild111
2 files changed, 0 insertions, 112 deletions
diff --git a/app-admin/keepass/Manifest b/app-admin/keepass/Manifest
index a8db08e87e86..bc4630ab04ee 100644
--- a/app-admin/keepass/Manifest
+++ b/app-admin/keepass/Manifest
@@ -1,2 +1 @@
-DIST KeePass-2.37-Source.zip 5080663 BLAKE2B bf74c93eb732d607fe87dc29d3e429b37f1052b258e980127ce1f687423a790bfe298f06c1c459888c60b066a45053447fbaed730e3d38cd6b6dd48d53fbdc34 SHA512 d094793a3216181ae375fb1343a809a20c358786bdf369c0171e5b7ca17a74bada314875cf410d84efaa4fa2b13e199de9be3c60f5f4e2c189241e4fffec8ad8
DIST KeePass-2.38-Source.zip 5091900 BLAKE2B 22e3f7046984204a3e0c4a1c6d8303661048bc0fee4bcdb7999b521d0ed6e5463d89044d2897cfec0c932349cc80a7b43d4c8dfbceb4f2e88041c642e0c0d231 SHA512 42fa7274874d4858da360a6772eb25adbf3a6dafe375093459d9a25903d8c159360ea722e969fe8b330bccf62ee5d381e131bd0ba075445932d8019eee19bf20
diff --git a/app-admin/keepass/keepass-2.37.ebuild b/app-admin/keepass/keepass-2.37.ebuild
deleted file mode 100644
index 4b997c59a7eb..000000000000
--- a/app-admin/keepass/keepass-2.37.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils gnome2-utils xdg-utils
-
-MY_PN="KeePass"
-DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
-HOMEPAGE="https://keepass.info/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="aot"
-
-COMMON_DEPEND="dev-lang/mono"
-DEPEND="${COMMON_DEPEND}
- app-arch/unzip
-"
-RDEPEND="${COMMON_DEPEND}
- dev-dotnet/libgdiplus[cairo]
-"
-
-S="${WORKDIR}"
-PATCHES=( "${FILESDIR}/${PN}-2.36-xsl-path-detection.patch" )
-
-src_prepare() {
- # KeePass looks for some XSL files in the same folder as the executable,
- # we prefer to have it in /usr/share/KeePass. Apply patch using base function.
- # This XSL file will not be upstreamed since the KeePass creator said that
- # including this patch would break the Portable USB version of KeePass
- # (which keeps/looks for xsl files in its own folder)
- default
-
- # Switch into build dir so the mono prepration script works correctly
- cd Build || die
- source PrepMonoDev.sh || die
- cd ../ || die
-}
-
-src_compile() {
- # Build with Release target
- xbuild /target:KeePass /property:Configuration=Release || die
-
- # Run Ahead Of Time compiler on the binary
- if use aot; then
- cp Ext/KeePass.exe.config Build/KeePass/Release/ || die
- mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
- fi
-}
-
-src_install() {
- # Wrapper script to launch mono
- make_wrapper "${PN}" "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
-
- # Some XSL files
- insinto "/usr/share/${PN}/XSL"
- doins Ext/XSL/*
-
- insinto "/usr/$(get_libdir)/${PN}/"
- exeinto "/usr/$(get_libdir)/${PN}/"
-
- doins Ext/KeePass.exe.config
-
- # Default configuration, simply says to use user-specific configuration
- doins Ext/KeePass.config.xml
-
- # The actual executable
- doexe Build/KeePass/Release/KeePass.exe
-
- # Copy the AOT compilation result
- if use aot; then
- doexe Build/KeePass/Release/KeePass.exe.so
- fi
-
- # Prepare the icons
- newicon -s 256 Ext/Icons_04_CB/Finals/plockb.png "${PN}.png"
- newicon -s 256 -t gnome -c mimetypes Ext/Icons_04_CB/Finals/plockb.png "application-x-${PN}2.png"
-
- # Create a desktop entry and associate it with the KeePass mime type
- make_desktop_entry "${PN}" "${MY_PN}" "${PN}" "System;Security" "MimeType=application/x-keepass2;"
-
- # MIME descriptor for .kdbx files
- insinto /usr/share/mime/packages/
- doins "${FILESDIR}/${PN}.xml"
-
- # sed, because patching this really sucks
- sed -i 's/mono/mono --verify-all/g' "${D}/usr/bin/keepass"
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-
- if ! has_version x11-misc/xdotool ; then
- elog "Optional dependencies:"
- elog " x11-misc/xdotool (enables autotype/autofill)"
- fi
-
- elog "Some systems may experience issues with copy and paste operations."
- elog "If you encounter this, please install x11-misc/xsel."
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}