summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-08 10:50:11 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-08 11:05:12 +0300
commit5812dc14100de7b4e02cb4cde1d6ce0560a43020 (patch)
treeb0da14a2d38f70b2d2bdcd5d799025658335adda /app-admin
parentmedia-video/mkvtoolnix: sync live (diff)
downloadgentoo-5812dc14100de7b4e02cb4cde1d6ce0560a43020.tar.gz
gentoo-5812dc14100de7b4e02cb4cde1d6ce0560a43020.tar.bz2
gentoo-5812dc14100de7b4e02cb4cde1d6ce0560a43020.zip
app-admin/awscli: add 1.25.25
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.25.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 1824219105cc..c1b7ad593a57 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST aws-cli-1.25.21.gh.tar.gz 2228274 BLAKE2B 3246bcc1607fa7a43cb081192176345c1
DIST aws-cli-1.25.22.gh.tar.gz 2228459 BLAKE2B e9ca58f6be9d5836b2b4d8ce51154ecd9dca3e443a120ff6ab3475b0777ca5e50c17a3c30641c57df1df63cc065fc0316b1e847b695bdfbe49a0a5b330912a74 SHA512 328303792a75c9f44c7e37e825ffb81aa2a071d4ae18b21c31f2c9abc5e0ae8f3ec079725847cd731d4cc49b5064a0244129176789f4ce0865e6d8cae0dda1e8
DIST aws-cli-1.25.23.gh.tar.gz 2229364 BLAKE2B 1610ceba16cc6555b333d1f2869f4c8667a7aecfb28ac21f46ebd1ca9a3f26da78d1f84816a7ec6c279273c5d17ab97e1963a73499c5a648571da0386f715b88 SHA512 8cc030c386b9a3d58ea2ff41d9a8da30f126707db1b9e8397ee676f3f9f4d0c8f74aa840307ba6664508d47e2f73d7fb3fe5090b7d117aab8d8b47b1b3a191eb
DIST aws-cli-1.25.24.gh.tar.gz 2229473 BLAKE2B 2937ca1016052732ff382b70c5a479250a139a9c556f1cf40a2903dac35f8fbe89575b1cd3bf787c23a0cb70ebe87fd7cf3952ce9eef08347c439e30a0efd3dd SHA512 7a0c7b3ac9cc9cedefe72ce9d7004afa5cf4b5cb25826153452fd83fdef89970d286e63c1e47f699b9d8bbe2cd39f7079a2154cd3d1064ecbd6d8b6ab244c9a2
+DIST aws-cli-1.25.25.gh.tar.gz 2230412 BLAKE2B 3dc6ab33083e0ff276c2f053675af7ad56287864d6112e8ff03270807bd68d8959753a20fb8b9569dce10c20cc1c6bfd4730b95139f95b911f30992eb38caedc SHA512 fb90e9132e8911acbc984154f739b9bdba77a805b0de0419ff500634af9428e88ff6220d2fc09b301f6af510559bfbec88ec6ec4c56e81e049145f9b43da6cfd
diff --git a/app-admin/awscli/awscli-1.25.25.ebuild b/app-admin/awscli/awscli-1.25.25.ebuild
new file mode 100644
index 000000000000..9f176fa05cc8
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.25.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}