summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-11 15:31:19 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-11 15:31:29 +0100
commit58d21e4a4ee241d8e0468da2176f09bb3706757e (patch)
treea8478a1d6a0c00bf6bc507429ba1da4a6f5750f8 /app-admin
parentmedia-radio/xlog: Version bump (diff)
downloadgentoo-58d21e4a4ee241d8e0468da2176f09bb3706757e.tar.gz
gentoo-58d21e4a4ee241d8e0468da2176f09bb3706757e.tar.bz2
gentoo-58d21e4a4ee241d8e0468da2176f09bb3706757e.zip
app-admin/keepassxc: Handle beta releases more gracefully.
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/keepassxc/keepassxc-2.4.0_beta2.ebuild4
-rw-r--r--app-admin/keepassxc/keepassxc-9999.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/app-admin/keepassxc/keepassxc-2.4.0_beta2.ebuild b/app-admin/keepassxc/keepassxc-2.4.0_beta2.ebuild
index b05a5089d561..c7e8d14ab636 100644
--- a/app-admin/keepassxc/keepassxc-2.4.0_beta2.ebuild
+++ b/app-admin/keepassxc/keepassxc-2.4.0_beta2.ebuild
@@ -69,6 +69,7 @@ src_prepare() {
}
src_configure() {
+
local mycmakeargs=(
-DWITH_GUI_TESTS=OFF
-DWITH_TESTS="$(usex test)"
@@ -79,6 +80,9 @@ src_configure() {
-DWITH_XC_SSHAGENT=ON
-DWITH_XC_YUBIKEY="$(usex yubikey)"
)
+ if [[ "${PV}" == *_beta* ]] ; then
+ mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
+ fi
cmake-utils_src_configure
}
diff --git a/app-admin/keepassxc/keepassxc-9999.ebuild b/app-admin/keepassxc/keepassxc-9999.ebuild
index 1b5f2654570d..85eaad62e18d 100644
--- a/app-admin/keepassxc/keepassxc-9999.ebuild
+++ b/app-admin/keepassxc/keepassxc-9999.ebuild
@@ -65,6 +65,7 @@ src_prepare() {
}
src_configure() {
+
local mycmakeargs=(
-DWITH_GUI_TESTS=OFF
-DWITH_TESTS="$(usex test)"
@@ -75,6 +76,9 @@ src_configure() {
-DWITH_XC_SSHAGENT=ON
-DWITH_XC_YUBIKEY="$(usex yubikey)"
)
+ if [[ "${PV}" == *_beta* ]] ; then
+ mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
+ fi
cmake-utils_src_configure
}