summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-06-09 22:50:50 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-06-09 22:51:37 -0500
commit6294ab61ad13da4a283554975b9f3d0c502a1f8d (patch)
tree3d7dfca5f31dd7697e2cd9e1fd2b3058ae8ca154 /app-admin
parentsci-libs/oce: adjust dependency on sci-libs/vtk (diff)
downloadgentoo-6294ab61ad13da4a283554975b9f3d0c502a1f8d.tar.gz
gentoo-6294ab61ad13da4a283554975b9f3d0c502a1f8d.tar.bz2
gentoo-6294ab61ad13da4a283554975b9f3d0c502a1f8d.zip
app-admin/rasdaemon: fix sysconfig dir
uses https://github.com/mchehab/rasdaemon/pull/46 Closes: https://bugs.gentoo.org/795132 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/rasdaemon/files/sysconfig-fix-0.6.7.patch32
-rw-r--r--app-admin/rasdaemon/rasdaemon-0.6.7.ebuild4
2 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/rasdaemon/files/sysconfig-fix-0.6.7.patch b/app-admin/rasdaemon/files/sysconfig-fix-0.6.7.patch
new file mode 100644
index 000000000000..ce4f5ce92bc2
--- /dev/null
+++ b/app-admin/rasdaemon/files/sysconfig-fix-0.6.7.patch
@@ -0,0 +1,32 @@
+From 2379c720a7e490854a2f352ca53af6fbd99c0832 Mon Sep 17 00:00:00 2001
+From: Matt Whitlock <whitslack@users.noreply.github.com>
+Date: Wed, 9 Jun 2021 10:25:18 -0400
+Subject: [PATCH] configure.ac: fix SYSCONFDEFDIR default value
+
+configure.ac was using AC_ARG_WITH incorrectly, yielding a generated configure script like:
+
+ # Check whether --with-sysconfdefdir was given.
+ if test "${with_sysconfdefdir+set}" = set; then :
+ withval=$with_sysconfdefdir; SYSCONFDEFDIR=$withval
+ else
+ "/etc/sysconfig"
+ fi
+
+This commit fixes the default case so that the SYSCONFDEFDIR variable is assigned the value "/etc/sysconfig" rather than trying to execute "/etc/sysconfig" as a command.
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index f7d1947..33b81fe 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -172,7 +172,7 @@ AC_SUBST([RASSTATEDIR])
+ AC_ARG_WITH(sysconfdefdir,
+ AC_HELP_STRING([--with-sysconfdefdir=DIR], [rasdaemon environment file dir]),
+ [SYSCONFDEFDIR=$withval],
+- ["/etc/sysconfig"])
++ [SYSCONFDEFDIR=/etc/sysconfig])
+ AC_SUBST([SYSCONFDEFDIR])
+
+ AC_DEFINE([RAS_DB_FNAME], ["ras-mc_event.db"], [ras events database])
diff --git a/app-admin/rasdaemon/rasdaemon-0.6.7.ebuild b/app-admin/rasdaemon/rasdaemon-0.6.7.ebuild
index c5aa842b5d02..add264d23745 100644
--- a/app-admin/rasdaemon/rasdaemon-0.6.7.ebuild
+++ b/app-admin/rasdaemon/rasdaemon-0.6.7.ebuild
@@ -25,6 +25,10 @@ RDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}/sysconfig-fix-0.6.7.patch"
+)
+
pkg_setup() {
linux-info_pkg_setup
local CONFIG_CHECK="~ACPI_EXTLOG"