summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-06-15 10:49:57 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-06-15 10:50:54 -0500
commit6b27de97c6a28b95b996b82b8a2003d1140cf223 (patch)
tree89dda2c64203e998596883d6bd96444fc7393068 /app-admin
parentsys-kernel/gentoo-sources: Cleanup of old 4.16.X kernels. (diff)
downloadgentoo-6b27de97c6a28b95b996b82b8a2003d1140cf223.tar.gz
gentoo-6b27de97c6a28b95b996b82b8a2003d1140cf223.tar.bz2
gentoo-6b27de97c6a28b95b996b82b8a2003d1140cf223.zip
app-admin/ansible: 2.5.5 bup2.5.5 bup
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-2.5.5.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index ce3d4d8564a7..69565c6b8999 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -3,3 +3,4 @@ DIST ansible-2.4.4.0.tar.gz 6512938 BLAKE2B 51e397d2242209271a8aef211c3bdeb34a15
DIST ansible-2.5.2.tar.gz 10105800 BLAKE2B 0d9080b666164c96c2a237f9a5f4b271a2fe9933d1999df85cd973df0cf85d850343bc33b8afb18c1bf0a7eecb2ab193e91c7a02c3e56e8a5e41338ce7a90081 SHA512 25568665b96ee9d7ca0888dadd90de178a9cc1da7dba07acb682ca4455ef91622344958ec2000eafbb4cfda87aec325be77d3d5b395aa4bbc2d180fad1a90a34
DIST ansible-2.5.3.tar.gz 10138567 BLAKE2B ea79156f531db1586899f18babc72165b64e7e2d42690f3ef15d790d2d80c12c9f9e1b70ab5fc7b863538e9209a8e98368d0110fc2a79c70c42726449917255c SHA512 74aa767118773aa557cd43f2a9e17322d7a6b45ea643a9175fe4f613fd4566453dc6f1859768fce179db3331b3beba103e89dfe4eae66ed82b1a83cd7d261269
DIST ansible-2.5.4.tar.gz 10146881 BLAKE2B 69aae30c39274ea6c082a995131054050942e334382ee6e815a0e54165c3daaf5f32e448e2d900259b39490460e0bd48c9e067fb9558276c5cea5c34027fc46b SHA512 4e39547c5df38e407b06e5f20f7caa50e599fa6283693afdbc2c808565593e908b2067b71fb287c4ad0aab8f283c8bb29bea438d534f827a37ed416c7325ea82
+DIST ansible-2.5.5.tar.gz 10150862 BLAKE2B 51184d11418c0a534c0176fcc6fde6da3c962e00502b354317b311d20122b28bbafbb8dfdfb7700a0153116c70396a882b538524395af590af16eeac043d0655 SHA512 a3d50539d2a109dc0bbcdb440e0800b917f63141dce935e6426cb6bdc51e3a93e02f05c23714c24ab00b19842a86677b8d2f2455d20ca15410fa8d3c8ba379ca
diff --git a/app-admin/ansible/ansible-2.5.5.ebuild b/app-admin/ansible/ansible-2.5.5.ebuild
new file mode 100644
index 000000000000..8f63e8546445
--- /dev/null
+++ b/app-admin/ansible/ansible-2.5.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1 eutils versionator
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+# not included in release tarball
+RESTRICT="test"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+}